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1. DraftSight Customization 
Setting up the options of an applications order to fit personal preferences, the environment 

or workflows, is usually one of the first tasks that users set out to. This document provides 

information on how to customize the DraftSight User Interface and program environment. 

In DraftSight, most of these preferences / options are accessible under Options.  

The Options command lets you configure program operating parameters, customize 

settings, set shortcuts for commands, and set other preferences. All these are grouped in six 

major groups: 

 File Locations 

 System Options 

 User Preferences 

 Drawing Settings 

 Drafting Styles 

 Profiles 

To access the Options dialog box: 

Type in Command Line: Options 

or 

Menu: Tools > Options (Classic Interface) 

 

or 
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Manage > Options (Drafting and Annotation Interface) 

 

To search for specific options in the Options dialog box: 

1. In Find, type a term or system variable to search for related options.  

2. In the drop-down list, select an option. In the Options dialog box, the option displays. 

 

 

2. Customizing the User Interface 
The Customize command lets you customize user interface elements such as menus, 

toolbars, ribbon tabs and panels, quick access toolbar, and working spaces. 

In this topic, you can find information on  

 Managing Customization Files 

 Managing Commands 

 Managing the Interface 

 Setting Mouse Actions 

 Managing Keyboard Shortcuts 

 Managing User Interface Profiles 

2.1. Managing Customization Files 
You can manage the customization files you use. Customization files store the elements that 

comprise the user interface. 
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2.1.1. To manage customization files: 

 

 

 

1. Click Tools > Customize Interface (or type Customize).  

2. In the Customize dialog box, in Source, select one of the following:  

 All Customization Files to become the base for adding or modifying 

interface elements.  

 A specific customization file (.xml format) on which to work.  

3. Click Load customization file  to load a customization file located outside 

the default folder for customization files.  

4. Click Create customization file   to create a new customization file. In the 

Create Customization File dialog box, for:  

 Name, type the name for the new customization file.  

 Path, accept the location for the new file or browse to a location.  
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2.2. Managing Commands 
Use the Commands page of the Customize dialog box to manage commands and 

command sequences for use in user interface elements. 

2.2.1. To manage commands for use in User Interface elements: 

 

1. Click Tools > Customize Interface (or type Customize).  

2. In the Customize dialog box, click Commands .  

3. To add a command to the list of commands, click Add Command  .  

An empty command entry is added to the commands list, labeled "Command" 

as placeholder for a new command. 

See below for a description to edit command entries. 

4. To remove a command from the commands list, click Remove Command .  

5. To expand the Icon Explorer, click Show icon explorer . In Filter, select 

whether to show All Icons, Small Icons, or Large Icons in the Icon Explorer.  

6. Click OK.  

2.2.2. To edit command entries 

1. In the Customize dialog box, in the commands list, select a command entry.  
2. In the Name field, label the command entry.  
3. For Command string, type a command, command sequence, or command 

option.  

Start the expression with ^C^C to ensure a running command is cancelled 
when invoking the command or command sequence. 

Example: ^C^C_circle \4;circle \2 

4. To expand the Icon Explorer, click Show icon explorer .  
5. From the Icon Explorer drag a small icon and a large icon to the 

corresponding Small and Large fields of the new command entry. These 
icons are used for menus and toolbars.  

The location and file name of the icons displays in Small icon location and 
Large icon location. 

6. For Description, type a description to display in the status line when you 
move the pointer over the corresponding command in a menu or toolbar.  
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3. Managing the User Interface 

This section discusses: 

 Quick Access Toolbar 
 Ribbon Tabs and Panels 
 Menus and Toolbars 

 

 

3.1. Managing the User Interface: Menus and Toolbars 

Use the Interface page of the Customize dialog box to create and modify quick 
access toolbars, ribbon tabs and panels, menus, and toolbars. 

You can rearrange existing items, add new items, and modify entries and command 
sequences associated with them. 

To remove a UI item, select it and click Remove . 
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3.2. Quick Access Toolbar 
The Quick Access Toolbar is a small toolbar that lets you access frequently used 

commands. 

 

3.2.1. To manage quick access toolbars 

1. Click Tools > Customize Interface (or type Customize).  

2. In the Customize dialog box, click Interface .  
3. Expand Quick Access Toolbars.  
4. In Quick Access Toolbar, select whether to display All Quick Access 

Toolbars of the current customization source or a specific quick access 
toolbar.  

5. Expand the quick access toolbar you want to edit.  

The command entries of the toolbar and their icons display. 

6. Click Show command explorer  to expand the Command Explorer.  
7. In Command Explorer, select a command entry and drag it to the quick 

access toolbar.  
8. Use the Find box to type a search string to reduce the entries in the 

Command Explorer.  
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3.2.2. To create a new quick access toolbar 

1. In the Customize dialog box, expand Quick Access Toolbars.  
2. In the list of quick access toolbars, right-click and click New Quick Access 

Toolbar.  

A new quick access toolbar is added to the list. 

3. Right-click the quick access toolbar and click Rename to edit the name.  
4. Add command items to the quick access toolbar.  

3.2.3. To add commands to a quick access toolbar: 

1. In the Customize dialog box, expand a quick access toolbar.  
2. Navigate to the location in the quick access toolbar where you want to place 

the new item.  

3. Click Show command explorer  to expand the Command Explorer.  
4. In Command Explorer, select a command entry and drag it to the quick 

access toolbar.  

3.2.4. To rename an entry in a quick access toolbar: 

1. In the Customize dialog box, expand a quick access toolbar.  
2. Right-click the entry to rename and click Rename.  
3. Type new text for the quick access toolbar entry.  

Note: The command sequence behind the entry does not change. 

3.2.5. To delete an entry from a quick access toolbar: 

1. In the Customize dialog box, expand a quick access toolbar.  
2. Right-click the entry to delete and click Delete.  

3.2.6. Tool Matrix 

The Tool Matrix is a collection of toolbars. When you open the Tool Matrix the first time, it is 

an empty panel. You need to drag toolbars onto the Tool Matrix 

The Tool Matrix is a user interface element that behaves like other palettes, such as the 

Properties palette or References palette. 

 To display the Tool Matrix 

Right-click the menu bar or a docked toolbar and select Tool Matrix (or type ToolMatrix).  

The Tool Matrix opens as floating or docked palette. 
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 To hide the Tool Matrix 

Right-click the menu bar or a docked toolbar and clear Tool Matrix (or type 

HideToolMatrix).   

- or - 

Click Close . 

 To place a toolbar on the Tool Matrix: 

Click the handle on the left of a toolbar   and drag the toolbar onto the Tool Matrix. 

 To remove a toolbar from the Tool Matrix: 

Click the title of the toolbar, and drag the toolbar onto the graphics area (to float it) or to a 

margin of the program's desktop (to dock it). 

 To rearrange toolbars on the Tool Matrix: 

Click the toolbar title and drag the toolbar onto the Tool Matrix.  

 To collapse a toolbar on the Tool Matrix: 

Click Collapse   on the toolbar. The icons of the corresponding toolbar are hidden. The 

toolbar is still part of the Tool Matrix. 

 To expand a toolbar on the Tool Matrix: 

Click Expand  on the toolbar.  

This shows the corresponding toolbar and makes the icons available. This shows the 

corresponding toolbar and makes the icons available. 

 To minimize the floating Tool Matrix: 

Click Minimize   on the Tool Matrix. The Tool Matrix minimizes to a two column 

panel. The toolbars are arranged as drop-down icon menus. 

 To set the floating Tool Matrix to its default width: 

Click Enroll  on the Tool Matrix.   
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3.3. Ribbon Tabs and Panels 
Ribbons provide tabs that organize application feature categories, such as drafting and 

modification (on the Home tab), inserting, and viewing. 

 

Each ribbon tab is composed of panels, which are a set of closely related commands 

needed to complete a task. 

3.3.1. To Manage Ribbon Tabs 

1. Click Tools > Customize Interface (or type Customize) .  
2. In the Customize dialog box, click Interface  
3. Expand Ribbon, then Tabs.  
4. In Tabs, select whether to display All Tabs of the current customization 

source or a specific tab.  
5. Expand the tab to view or edit.  

The tab panels display. 

6. Click Show ribbon explorer   to expand the Ribbon Explorer.  
7. Click a panel in the Tabs tree view to view a panel in the Panel Preview.  
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3.3.2. To Create New Ribbon Tabs 

1. On the Interface page of the Customize dialog box, expand Ribbon, then 
Tabs.  

2. In the Tabs tree view, right-click and click New Tab.  

A new tab is added to the list. 

3. Click Show ribbon explorer  to expand the Ribbon Explorer.  
4. In Appearance, edit the tab name in Display text.  
5. Add panels to the tab.  

3.3.3. To add panels to ribbon tabs: 

1. On the Interface page of the Customize dialog box, expand Ribbon, then 
Tabs.  

2. Click Show ribbon explorer  to expand the Ribbon Explorer.  
3. Select an entry in Ribbon Panel Explorer and drag it into a tab.  

Note: You can drag a panel to another position in the Tabs tree view list at 
any time. 

Note: In the Tabs tree view, right-click to create, rename, duplicate, or delete 
tabs. 

3.3.4. To Manage Ribbon Panels 

1. Click Tools > Customize Interface (or type Customize) .  
2. In the Customize dialog box, click Interface .  
3. Expand Ribbon, then Panels.  
4. In Panels, select whether to display All Panels of the current customization 

source or a specific panel.  
5. Expand the panel to view or edit.  

The panel items display. 

6. Click Show ribbon explorer  to expand the Ribbon Explorer.  
7. Click a panel in the Panels tree view to view a panel in the Panel Preview.  
8. Click a command in the Panels tree view to highlight a command button in the 

Panel Preview.  
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3.3.5. To create new ribbon panels 

1. On the Interface page of the Customize dialog box, expand Ribbon, then 
Panels.  

2. Click Show ribbon explorer  to expand the Ribbon Explorer.  
3. In the Panels tree view, right-click and click New Panel.  

A new panel is added to the list. 

4. In Appearance, edit the panel name in Display text.  
5. Add panel items to the panel as described next.  

3.3.6. To add new items to a new ribbon panel 

1. On the Interface page of the Customize dialog box, expand Ribbon, then 
Panels.  

2. Click Show ribbon explorer  to expand the Ribbon Explorer.  
3. In the Panels tree view, right-click and click New Row.  

A new row is added to the list. 

4. From the Command Explorer, drag a command entry onto the new row.  
5. Click In Appearance, specify the Button style.  
6. Add more panel elements (see Ribbon Panel Elements).  

 

3.4. Ribbon Panel Elements 
A panel can contain the following elements: 

Type Description 

Row Contains sub-panels, drop-down menus, and 
command buttons. 

Sub-panel Creates an area with rows within a panel. 
They cannot contain drop-down menus or 
command buttons. 

Drop-down menu Contains command buttons. In Appearance, 
specify the drop-down behavior, split button 
list style, and button style for the commands. 

Command button Executes commands from a ribbon. 
Command buttons usually have icons 
associated with them. In Appearance, 
specify the button style of the command 
button. 

Separator Separates groups of similar commands in 
drop-down menus. 
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3.5. Placing Panel Elements 

To create a new row, sub-panel, or drop-down menu, right-click in the Panels tree 
view. 

To place a command button or a control element in a panel, drag it from the 
Command Explorer into a panel row or panel drop-down menu. 

3.6. Setting the Appearance of Drop-down Menu Buttons and 

Command Buttons 
The Appearance area of the Ribbon Explorer lets you specify the display mode of drop-

down menu buttons (split buttons) and command buttons. 

3.6.1. Drop-down Behavior 

You can define the display mode of split buttons that display drop-down menus in panels: 

Type Description 

Split with recent Displays the icon and text of the recently 
selected drop-down menu item. 

Split with recent (Static) Displays the icon of the recently selected 
drop-down menu item, but the text is static 
(the text you defined as the drop-down menu 
title in the panel tree view). 

Split Uses a fixed icon. The drop-down menu 
displays text items. If the icon is not 
specified, Split behaves like Split with 
recent. 

Drop-down menu with recent Same as Split with recent. 

Drop-down menu Same as Split. 

 

3.6.2. Split Button List Styles 

You can define the display of drop-down menu list buttons. The default is Icons and Text, 

but you can specify Icons and Bold Text or Icons only. 

3.6.3. Button Styles 

You can define the button style for drop-down menu buttons and command buttons: Large 

buttons with text, Large buttons without text, or Small buttons without text. Do not use 

small buttons on stacked rows on panels. 

Tip: In the Panels tree view, right-click to create, rename, duplicate, or delete panels. Right-

click panel items to add command buttons, drop-down lists, rows, sub-panels, and 

separators. 
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3.7. Menus and Toolbars 
 

 

3.7.1. To Manage Menus and Toolbars 

1. Click Tools > Customize Interface (or Type Customize). 

2. In the Customize dialog box, click Interface . 

3. Expand Menus. 

4. In Menu, select whether to display All Menus of the current customization source or 

a specific menu (such as File, Edit, or View). 

5. Expand the menu you want to edit.  

The command entries of the menu and their icons or sub menus display. 

6. Expand Toolbars. 

7. In Toolbar, select whether to display All Toolbars of the current customization 

source or a specific toolbar (such as Standard, Layers, or Properties). 

8. Expand the toolbar you want to edit.  

The command entries of the toolbar and their icons display. 

9. To remove a selected command from a menu or toolbar, click Remove . 

10. To expand the Command Explorer, click Show command explorer . 

11. To insert a command or option in a menu or toolbar, select an entry in Command 

Explorer and drag it to a menu or toolbar. 

12. Use the Find box to type a search string to reduce the entries in the Command 

Explorer. 
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Note: Use the Commands section of the Customize dialog box to add and edit commands. 

You cannot edit the command or command sequence behind a menu or toolbar entry in the 

Interface section. 

 

3.7.2. To Create a New Menu or New Toolbar 

1. In the Customize dialog box, expand Menus or Toolbars. 

2. In the list of menus or toolbars, right-click and click New menu or New toolbar.  

A new menu or toolbar is added to the list. 

3. Right-click the menu or toolbar and click Rename to edit the name. 

4. Add command items to the menu or toolbar as described next. 

3.7.3. To Insert an Entry into a Menu or Toolbar 

1. In the Customize dialog box, expand a menu or toolbar. 

2. Navigate to the location in the menu or toolbar where you want to place the new item. 

3. Click Show command explorer   to expand the Command Explorer. 

4. In Command Explorer, select a command entry and drag it to the menu or toolbar. 

5. Right-click a menu or toolbar and click New separator to insert a separator. 

6. Right-click a menu and click New sub menu to insert a sub menu. 

3.7.4. To Rename an Entry in a Menu or Toolbar 

1. In the Customize dialog box, expand a menu or toolbar. 

2. Right-click the entry to rename and click Rename. 

3. Type new text for the menu or toolbar item. 

Note: The command sequence behind the item does not change. 

3.7.5. To Delete an Entry in a Menu or Toolbar 

1. In the Customize dialog box, expand a menu or toolbar. 

2. Right-click the entry to delete and click Delete. 
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4. Setting Mouse Actions 
Use the Mouse Actions page of the Customize dialog box to define what happens when 

you right-click or double-click the mouse. You can also define common and contextual 

shortcut menus. 

 

4.1. To Define Actions for Right-Clicks 
1. Click Tools > Customize Interface (or type Customize). 

2. In the Customize dialog box, click Mouse Actions . 

3. Expand Right Clicks. 

4. For Right Click, Shift+Right Click, Ctrl+Right Click, and Ctrl+Shift+Right Click 

select a menu, command, command sequence, or option to issue. 
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4.2. To Define Actions for Double-Clicks 
1. In the Customize dialog box, expand Double Clicks. 

2. In Entity, select an entity type. 

3. In Command Name, select a command to execute when you double-click the 

specified entity. 

4. To add an entity type to the list, click Add . 

5. To expand the Command Explorer to drag a command name to an entity type in the 

list, click Show command explorer . 

6. To remove an entity type from the list, click Remove . 

 

4.3. To Manage Shortcut Menus 
1. Click Tools > Customize Interface (or type Customize). 

2. In the Customize dialog box, click Mouse Actions . 

3. Expand Shortcut Menus > Common or Contextual. 

4. In Menu, or in the list of shortcut menus, select a shortcut menu. You can edit 

common shortcut menus: 

 The Default Menu displays if you right-click when no command is active. 

 The Edit Menu displays if you right-click when drawing entities are selected. 

 The Command Menu displays if you right-click when a command is active and 

no shortcut menu is defined for that command. 

 The contextual menus display if you right-click when a specific command is 

active. 

5. To insert a command or option in a shortcut menu: 

a) Click Show command explorer . 

b) Under Command Explorer, select an item and drag it to a menu or toolbar. 

7. To replace a command or option, select an item in a shortcut menu, then select 

another command or option in Command. 

8. To remove a command from a shortcut menu, select an item in a shortcut menu and 

click Remove  (the option is available for contextual shortcut menus only). 
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4.4. Mouse Gestures 
You can use a mouse gesture as a shortcut to execute a command, similar to a keyboard 

shortcut. Once you learn command mappings, you can use mouse gesture to invoke 

mapped commands quickly. 

To activate a mouse gesture, from the graphics area, right‐drag in one of four directions: up, 

down, left or right. When you right‐drag, a guide appears, showing the command mappings 

for the gesture directions. The guide highlights the command you are about to select. 

To cancel a mouse gesture, release the mouse within the mouse gesture guide. 

 

 To use a mouse gesture to invoke a pre‐assigned command 

1. Click Tools > Mouse Gestures (or Type Gesture). In a Drafting &Annotation UI, Go to 

Manage> Mouse Gestures. 

2. To display eight commands in the mouse gestures guide, click 8 Gestures and click OK. 

3. From the graphics area, right‐drag in the gesture direction that corresponds to the 

command. 

The mouse gesture guide appears, highlighting the icon for the command mapped to the 

direction of your gesture. 

For example, with a drawing open, right‐drag the mouse to the right, dragging toward the 

highlighted command. 

4. Continue to right‐drag through the command icon, releasing after you pass through the 

command region of the mouse gesture guide. 

The command is invoked. 
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 To disable mouse gestures: 

1. Click Tools > Mouse Gestures. 

2. Clear Enable mouse gestures. 

 Reassigning mouse gestures: 

There are 8 pre‐assigned commands mapped to mouse gestures, one command for each of 

eight mouse gesture directions. 

By default, 4 of the pre‐assigned commands are available in the mouse gesture guide. 

You can customize the commands assigned to mouse gestures. 

1. Click Tools > Mouse Gestures. 

2. Set Category to All Commands. 

3. Click the Select column to view the current mouse gesture commands. 

4. Decide which command to add, selecting from available commands. 

5. Choose one of the mouse gesture directions to reassign, and in the row for the new 

command, select the mouse gesture direction from the list.. 

By default, four directions are available. Select 8 Gestures to assign commands for eight 

gesture directions: 
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5. Managing Keyboard Shortcuts 

 

5.1. Default Shortcuts 
Keyboard Shortcuts are divided in two categories: Function Keys, and Keyboard 

Shortcuts. Below, tables with the default settings (on install): 

Function Keys 

Function Key Description Related Commands 

Esc Cancels current command - 

F1 Displays online Help Help 

F2 Shows and hides the 
command history in a 
separate Command Window 

CommandHistory, 
HideCommandHistory 

F3 Turns EntitySnaps on and off EntitySnap, -EntitySnap 

F4 - - 

F5 Switches the isometric grid to 
next isoplane 

IsometricGrid 

F6 - - 

F7 Turns the grid display on and 
off 

Grid 

F8 Turns ortho mode on and off Ortho 

F9 Turns snap mode on and off Snap 

F10 Turns Polar Guides on and 
off 

- 

F11 Turns Entity Tracking on and 
off 

- 

F12 - - 

Ctrl + F4 Exits the drawing but not the 
program 

Close 

Alt + F4 Exits the Program Exit 
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Keyboard Shortcuts 

Keyboard Shortcut Description Related Commands 

Ctrl + 0 Maximizes the drawing area or 
returns to generic display mode 

FullScreen, HideFullscreen 

Ctrl + 1 Turns the Properties Palette on and 
off 

Properties, HideProperties 

Ctrl + 9 Turns the Command Window on 
and off 

CommandWindow, 
HideCommandWindow 

Ctrl + A Selects all non-frozen entities in the 
current Viewport 

SelectAll 

Ctrl + B Toggles snap mode during 
command execution 

Snap 

Ctrl + C Copies entities to the clipboard ClipboardCopy 

Ctrl + Shift + C Copies entities with a specified 
reference point to the clipboard 

Copy@ 

Ctrl + F Finds and replaces Text in Notes, 
Annotations, and Dimension Text 

Find 

Ctrl + G Toggles grid display during 
command execution 

Grid 

Ctrl + K Attaches a hyperlink to entities or 
modifies an existing hyperlink 

Hyperlink 

Ctrl + L Toggles ortho mode during 
command execution 

Ortho 

Ctrl + N Creates a new drawing file New 

Ctrl + O Opens an existing drawing file Open 

Ctrl + P Plots the drawing to a plotter, 
printer, or file 

Print 

Ctrl + Q Exits the software Exit 

Ctrl + R Cycles through Tiled Views without 
clicking 

- 

Ctrl + S Saves the drawing under the 
current file name or a specified 
name 

Save 

Ctrl + Shift + S Saves an unnamed drawing with a 
file name or renames the current 
drawing 

SaveAs 

Ctrl + V Inserts data from the clipboard Paste 

Ctrl + Shift + V Inserts entities from the clipboard 
as a Block 

PasteAsBlock 

Ctrl + X Copies entities to the clipboard and 
deletes the entities 

Cut 

Ctrl + Y Reverses the effects of the 
previous U or UndoN command 

Redo 

Ctrl + Z Reverses the most recent 
command (Undo) 

U 

Del Removes highlighted entities from 
a drawing 

Delete 

Shift Enforces Ortho Mode Ortho 
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5.2. Managing Keyboard Shortcuts 
You can customize keyboard shortcuts and temporarily override the shortcuts through the 

Customize command's Keyboard tab. 

5.2.1. To Manage Keyboard Shortcuts 

1. Click Tools > Customize Interface (or type Customize). 

2. In the Customize dialog box, click Keyboard . 

3. Expand Keyboard Shortcuts > Shortcut Keys and Keyboard Shortcuts > 

Override Keys. 

4. To add new shortcuts to the lists, click Add , and in the Key column of the 

new row that appears in the list, hold a special key like Ctrl, Alt, or Shift and 

press another key on the keyboard for the shortcut. 

5. To associate an existing command sequence to a shortcut, click Show 

command explorer  to expand the Command Explorer, then drag the 

command sequences to a new or existing keyboard shortcut in the list.  

For override keys, type a Function description and create a Macro. 

6. To remove a keyboard shortcut from the list, click Remove . 

6. Managing User Interface Profiles 
Use the UI Profile page of the Customize dialog box to manage user interface elements 

such as quick access toolbars, ribbon tabs, menus, toolbars, and other elements in 

individual UI profiles (also referred to as workspaces). 

Customization files store the UI profiles (workspaces) that comprise the user interface. 
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6.1. To Manage User Interface Profiles 
1. Click Tools > Customize Interface (or type Customize). 

2. In the Customize dialog box, click UI Profiles . You can also use the 

UIProfile command to open the UI Profiles page of the Customize dialog box. 

3. In Show, select one of the following: 

 All UI Profiles to become the base for adding or modifying user 

interface profiles. 

 A specific user interface profile. 

4. Expand UI Profiles. 

5. In the list, select a user interface profile (workspace). 

6. Do one of the following: 

 Double-click the Active column to make a workspace the current 

workspace. 

 Click New  to create a new workspace. 

 Click Delete  to remove the selected workspace. The Delete option is 

irrevocable after you click OK or Apply. 

 Right-click and click Rename to rename a workspace. 

 Double-click a Description cell to add or edit a workspace description. 

7. Click Apply. 

 

6.2. To Assign a Quick Access Toolbar to a Workspace 
1. In the Customize dialog box, under UI Profiles, expand UI Profiles > Quick 

Access Toolbar. 

2. In the list, click the Quick Access Toolbar cell of a workspace entry and select a 

quick access toolbar name. 

3. Click Apply. 

6.3. To Assign a Ribbon Tab to a Workspace 
1. In the Customize dialog box, under UI Profiles, expand UI Profiles > Ribbon 

Tabs. 

2. Click Show ribbon tab explorer  to expand the Ribbon Tab Explorer. 

3. In Ribbon Tab Explorer, select a ribbon tab name and drag it to the Ribbon 

Tabs cell of a workspace. 

4. You can : 

 Drag a ribbon tab entry to another position in the ribbon. 

 Right-click a ribbon tab entry and click Remove entry to delete the 

entry. 

5. Click Apply. 

Note: Do not assign ribbon tabs to workspaces that are designed to work with menus. 
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6.4. To Assign Menus to a Workspace 
1. In the Customize dialog box, under UI Profiles, expand UI Profiles > Menu Bar. 

2. Click Show menu explorer  to expand the Menu Explorer. 

3. In Menu Explorer, select a menu name and drag it to the Menu Bar cell of a 

workspace. 

4. You can: 

 Drag a menu entry to another position in the menu bar. 

 Right-click a menu entry and click Remove entry to delete the entry. 

5. Click Apply. 

Note:  Do not assign menus to workspaces that are designed to work with ribbons. 

6.5. To Assign Toolbars to Display to a Workspace 
1. In the Customize dialog box, on the UI Profiles section, expand UI Profiles > 

Toolbars. 

2. Click Show toolbar explorer  to expand the Toolbar Explorer. 

3. In Toolbar Explorer, select a toolbar name and drag it to the Toolbars 

Displayed cell of a workspace. The order of the toolbar entries does not matter. 

4. To delete an entry from the list of toolbars, right-click the entry and click Remove 

entry. 

5. Click Apply. 

Note: For workspaces that are designed to work with ribbons, the list of toolbars to display 

typically remains empty. 

6.6. To Set the UI Elements to Display When the Workspace 

Changes 
1. In the Customize dialog box, under UI Profiles, expand UI Profiles > Elements. 

2. Double-click cells in the table to select or clear the UI elements to display when 

the workspace changes: 

 status bar 

 command prompt 

 tool matrix 

 Options toolbar 

 Properties palette 

 References palette 

 Lighting palette 

3. Click Apply. 

6.7. Displaying and Hiding Toolbars 
You can display and hide toolbars. You can drag and drop toolbars to convenient locations 

in the application window. You can also dock them below the menu bar or at the left and 

right margins of the application window. 
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6.7.1. To Display or Hide Toolbars 

1. Type Toolbars at the command prompt. 

2. In the Specify Toolbars dialog box, select or clear the toolbars to display or hide. 

3. For Name, type text to search for toolbars. 

4. Click Customize to open the Customize dialog box which lets you add or modify 

toolbars. 

5. Click Delete to permanently delete the selected toolbar. 

7. Setting User Preferences and System Options 
The Options command lets you configure program operating parameters, customize 

settings and shortcuts for commands, and set other preferences. 

The following sections are available in the Options dialog box: 

 File Locations 

 System Options 

 User Preferences 

 Drawing Settings 

 Drafting Styles 

 Profiles 

To search for specific options in the Options dialog box: 

1. In Find, type a term or command variable to search for related options. 

2. In the drop-down list, select an option.  

In the Options dialog box, the option displays. 

7.1. Setting File Location Options 
 

 

The File Locations page of the Options dialog box lets you view, set, and edit default paths 

and/or file names. 
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The system uses these locations to search for files or write files, such as drawing or 

temporary file locations, font files and folder(s), and customization file(s) and folder(s). 

 To view, add, or modify file locations: 

1. Click Tools > Options (or type Options).  

In the Options dialog box, click File Locations . 

- Or- 

Type FileLocations. 

2. Expand a node to view or set a specification. 

3. Select a path or file and click Browse (or double-click a folder or file location) 

to navigate to a new item. 

4. Click OK 

7.1.1. Drawing Support 

 
 

 Drawing Support: 

 Alternate Font File: Sets the font to use when the current font 

is not available. The standard and user-defined TextStyles in 

drawings are based on font files. 

 Drawing Files Location: Specifies the search location for 

drawings. The location is used when you use Open, Save, 

SaveAs, or other file commands. 

 Drawing Template File Location: Specifies the drawing 

template file location. 

 External References Files Location: Specifies the search 

location for external References. The location is used when 

you use the AttachDrawing command. 

 Font Mapping File: Sets the file that defines font file 

mappings to use when a font file referenced in a TextStyle is 

not available. 
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 Library Files Location: Specifies the search location for 

Blocks for the InsertBlock command. 

 LineStyle File: Specifies the search location for LineStyle 

files. 

 Print Settings Location: Specifies the default location for 

Print Configuration files. 

 RichLine Style File: Specifies the search location for 

RichLineStyle files. 

7.1.2. Interface 

 
 

 Interface 

 Alias File Location: Specifies the search location for the Alias 

Commands file. 

 Custom Icon Location: Specifies the search location for 

custom icon files for use with the Customize command to add 

icons to toolbars and menus. 

 Customization File: Specifies the search location for the main 

customization file supplied as base for the Customize 

command. 

 Menu Files: Specifies the search location for Menu 

customization files. 



DraftSight - Configuration & Basic Customization 

35 

 

3
D

S
.C

O
M

 ©
 D

a
s
s
a

u
lt
 S

y
s
tè

m
e

s
  

| 
 C

o
n

fi
d
e

n
ti
a

l 
In

fo
rm

a
ti
o

n
  

| 
 0

1
/0

2
/2

0
1

2
  
re

f.
: 

D
o
c
u

m
e

n
t_

R
e
fe

re
n

c
e

 |
 

7.1.3. System 

 
 

 System 

 Dictionary Files: 

Custom Dictionary File: Specifies the location for the custom 

spelling dictionary for use with the SpellCheck command. 

Main Dictionary Files: Specifies the dictionaries to use with 

the SpellCheck command. Select a language and click 

Activate to set the active language dictionary.  

 Font File Search Path: Specifies the search location for font 

files. The standard and user-defined TextStyles in drawings 

are based on font files. 

 Help File: Specifies the folder and name of the help file used 

by the Help command. 

 Log File Location: Specifies the location where the log file of 

document history is saved. 

 Support Files Search Path: Specifies the search location for 

add-in applications, area Hatch patterns, customization files, 

drawing files, fonts, and LineStyle files. 

 Temporary File Location: Specifies the location for temporary 

drawing files that have not been saved. 
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7.2. System Options 
 

 

The System Options page of the Options is where you can define general operating options.  

 To Set general options:  

1. Click Tools > Options (or type Options).  

In the Options dialog box, click System Options . 

- Or - 

 

Type SystemOptions. 

7.2.1. General 
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 Expand General to set: 

 Merge Zoom and Pan for Undo: Groups consecutive Zoom 

and Pan commands as a single action for Undo and Redo 

commands. 

 Show Print Configuration Manager on creation of new 

Sheets: Lets you set up a Print Configuration when you 

activate a new Sheet. 

 Maximum command history output lines: Specifies the 

maximum number of lines displayed on the Command History 

Window before you are prompted to press Enter to continue. 

Applies to commands that display long lists. 

 Show notification for missing external references: Displays 

a pop-up alert when you open a drawing and one or more 

externally referenced files are missing or cannot be loaded 

because they are corrupted. 

 Single document interface mode: Specifies that one instance 

of the application can open only one drawing at a time. 

 File thumbnail size: Specifies the size of file thumbnail 

preview images which display when you select a drawing in the 

operating system's file manager or in the Open dialog box. The 

setting applies to drawing files when you save them. The 

thumbnail size influences the drawing file size. You can set a 

value from 0 (very small thumbnails) to 8 (very large 

thumbnails). 

 Help make DraftSight product better by automatically 

sending your log files to DS SolidWorks Corporation. 

When checked, if the application fails unexpecteddly and 

generates a performance Log (Crash Report), it automatically 

sends the Log to our Development Team for further analysis. 

 

 Expand License to set Timeout setting (DraftSight Enterprise 

Only): 

 Use Return license if idle for more than « X « minutes  in 

order to set the idle time until the application returns the 

License to the License Manager application, so that it can be 

available to other users (Timeout Setting). 

 

 Expand Coordinate input override to set: 

 Use ESnaps: EntitySnaps input overrides coordinate input. 

 Coordinate input overrides ESnaps: Keyboard input 

overrides EntitySnaps coordinate input. 

 Coordinate input when running scripts (keyboard): 

Keyboard input overrides EntitySnaps coordinate input except 

in scripts. 

 

 



DraftSight - Configuration & Basic Customization 

38 

 

3
D

S
.C

O
M

 ©
 D

a
s
s
a

u
lt
 S

y
s
tè

m
e

s
  

| 
 C

o
n

fi
d
e

n
ti
a

l 
In

fo
rm

a
ti
o

n
  

| 
 0

1
/0

2
/2

0
1

2
  
re

f.
: 

D
o
c
u

m
e

n
t_

R
e
fe

re
n

c
e

 |
 

 Expand Proxy server settings to set specifications if your system 

is part of a network using a proxy server: 

 Type: Sets the type of the proxy server (Socks5, HTTP, HTTP 

Caching, or FTP Caching). 

 Host: Sets the IP address of the host to which you are 

connected. 

 Port: Sets the port for the proxy server. 

 User: Sets the user name to identify you in the network 

environment. 

 Password: Sets your login password.  

Note: Changes to the Proxy Login credentials will not be reflected automatically to 

DraftSight : If changes are made, you will need to manually update the information here. 

 

 Expand Application language to set the Language used by the 

application in the User Interface, Command entry, and Help files. 

The language can also be set by using the command 

_LANGUAGE.  

7.2.2. Display Options 
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 Expand Display. 

 Expand Screen options to set: 

 Show scroll bars: Turns on and off the display of scroll bars in 

the drawing window.  

 Use large icons: Uses large buttons for toolbars.  

 Expand Command window text to set: 

 Font: Sets the font for the command window prompt and 

messages. 

 Size: Sets the text size for the command window. 

 Command line text : Sets the text to display as the prompt in 

the command line. 

 

 Expand AutoCompletion to set options for auto-completion of 

command entries (Professional & Enterprise versions only). You 

can use the following options:  

 Auto selection of closest suggestion: Automatically selects 

the command or variable name that is closest to what you 

entered when you press Enter. Otherwise you need to enter 

the complete name or select an entry from the suggestion list. 

 Display suggestion list : Specifies whether a suggestion list 

displays as you type a command name. If you display the 

suggestion list, you can set: 

o Suggestion list delay time. Sets a delay time (in 

milliseconds) before the command names suggestion 

list displays. 

o Include aliases in list. Includes alias command names 

in the suggestion list. 

o Display commands with aliases. Displays the 

command name in brackets after the alias name in the 

suggestion list. 

o Include command variables. Includes command 

variable names in the suggestion list. 

o Include mid-string search. Browses command names 

for occurences of the string you type not only for initial 

characters, but also among whole command names. 

Note : When you enter a command and the suggestion list displays, right-click the list to set 

options described above. 

 Expand Element Colors to set display colors of user interface 

elements such as the Model and Sheet background, cursors, and 

crosshairs. You can use the following options: 

 Color: Applies the selected color to the selected display 

element. 
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 Reset All: Sets all user interface elements to the default 

colors. 

 Reset Selected Item: Sets the selected display element to its 

default color. 

 Expand Drawing tabs to set the following: 

 Show drawing tabs : Controls drawing tab display at the top 

of the drawing windows area. 

 Display settings. Select one of the following:  

o List View : Displays non-graphical lists of workspaces. 

o Panel preview. Displays thumbnails for each drawing 

workspace (model and layout sheets) below tabs 

(default). 

7.2.3. Graphics Area Options 

 

 Expand Graphics Area to set: 

 Display cursor as crosshair: Displays the pointer in form of 

crosshairs, even if no command is active. 

 Display ESnap tooltips: Determines whether tooltips are 

displayed whe the pointer passes over a point where an entity 

snap mode can be applied. 

 Show background: Determines whether to display colors in 

the background of user-defined Views. 

 Show hyperlink pointers, tooltips, and shortcut menus: 

Determines whether to show hyperlinks, tooltips, and shortcut 

menus whenever the pointer passes over an entity. 

 Pointer size: Specifies the size of the crosshairs that act as 

the pointer. Set a value between 1 and 100. If you type 100, 

the crosshairs pass over the full screen. 

 Display entity transparency: Determines whether to display 

the transparency of entities. The option does not affect print 

output transparency. 

 Locked layer fading: Determines whether to fade entities on 

locked layers to contrast them with entities on unlocked layers 

and reduce the display complexity of the drawing. Set a value 

between 0 and 90% where 0% means no fading. 

 

 

 

mk:@MSITStore:C:/Program%20Files/Dassault%20Systemes/DraftSight/Help/english/DraftSight.chm::/html/crosshairs.htm
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7.2.4. Open and Save As Options 

 Expand Open / Save As to set : 

 Open documents of type: Sets the default file type (.dwg, 

.dxf, .dwt) used when you open or insert drawings, or attach 

Referenced drawings.  

 Save documents as type: Sets the default file type (.dwg or 

.dxf) and version when you save drawings. 

 Preserve original file format : Saves the file in the .dwg or 

.dxf version used on the last save operation/file creation. 

 Expand Template file name for SmartNew to set the path and name 

of a drawing template file (.dwt). Click Browse to browse for the 

template file. 

 Expand Open with encoding to specify how to open drawings if the 

drawing’s codepage differs from the computer’s operating system 

codepage. Codepages determine character encoding. Select an 

option: 

 Open file as usual: Maintains the drawing’s codepage.  

 Open file with system codepage: Switches to the computer’s 

operating system codepage. 

 Check file codepage and prompt: Lets you specify the 

codepage to use when you open a drawing with a codepage 

that differs from the OS codepage.  

7.2.5. Printing Options 

 Expand Printing to set : 

 Print log files:  

o Location : Sets the path for the print and publish log 

files. Click Browse to browse/set the log file folder. 

o Save Print logs : Creates print job log files which are 

saved in the comma separated value format (.csv).  

o Log style : (available if you selected Save print logs): 

One log per print stores information about all print jobs 

in a single log file. When cleared, information is stored 

about each print job in separate log files 

 Expand Print style file location to set : 

 Print style file location: Sets the path for PrintStyle definition 

files. Click Browse to browse for the PrintStyle file folder. 

 Expand Default settings to set : 

 Default type : (determines the behavior for new drawings, not 

for the current drawing): 
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o Use named print styles : Uses user-defined 

PrintStyles. 

o Use color-dependent print styles: Uses color-

dependent PrintStyles. 

 Default PrintStyle: Sets the default PrintStyle file. 

o Override print style for entities (available if you 

selected Use named print styles): Overrides the 

Default PrintStyle table for entities. The settings 

available depend on the Default PrintStyle setting. 

 Override print style for layer 0 (available if you selected Use 

named print styles): Overrides the Default PrintStyle table 

for entities or Layer 0. The settings available depend on the 

Default PrintStyle setting.  

 Expand General Options to set : 

 Keep paper size when changing printer: When you change 

the printer in the Print dialog box, the paper size is maintained 

if it is supported by the specified printer. When cleared, the 

default format displays for paper size.  

 Display paper background :  On Sheet tabs, the Sheet 

extends are visualized by a gray background.  

 Display printable area : On Sheets tabs, a dashed rectangle 

visualizes the printable area and the non-printable margins of 

the selected printer associated with the Sheet..  

7.2.6. Auto-save & Backup Options 

 

 Expand Auto-save & Backup to set : 

 Automatic save file location: Sets the folder for automatically 

generated saved files. Click Browse to browse for the folder. 

 Auto-save/backups:  

o Enable auto-save: Automatically saves the drawing. 

You can specify the interval for auto-save in minutes. 

o Save backup at each save: Sets whether you want to 

create a backup copy each time the document is saved. 

o Use original format: Specifies whether the backup file 

is saved in its original drawing file version or in the 

current file version. 
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7.2.7. Drawing File Defaults 

 Expand Drawing File Defaults to set : 

 Block insertion units sets preferences to determine the 

default scale when you insert Blocks or drawings into a 

drawing: 

o Units for inserting entities: Sets the source contents 

units. If you select Unitless, the entity is not scaled 

when inserted. 

o Active drawing units: Sets the target drawing units. 

7.2.8. Customizing the Default Scale List 

Lists of scales are available when you print, manage Print Configurations, or scale Viewports 

on layout Sheets. 

The Default Scale List determines the Drawing Scale List for new drawings, which are 

created without template drawings. 

To change the scale list in an existing drawing template file, open the drawing template file 

(*.dwt), and customize the Drawing Scale List of the template file.  

 To Customize  the Default Scale List: 

5. Do one of the following: 

 Click Tools > Options (or type Options). 

In the Options dialog box, click System Options  

 Type SystemOptions. 

6. Expand Default Scale List. 

7. In File, the path and name of the scale list file, an .xml file, is displayed. 

If necessary, change the file setting. Click Browse to navigate to the scale list 

file. 

8. Click Metric or Imperial to display to the corresponding scale list. 

9. Click Add to add a new scale to the list: 

 In the Scale Name column of the new list item, type a name for the 

new scale. 

 In Paper Units, type a number. The ratio between between paper units 

and drawing units determines the scale applied when selecting the 

scale name in a scale list. 

 Click Move up to move the selected item up in the list. 

 Click Move down to move the selected item down in the list. 

 Click Delete to remove the selected item from the list. 

 Click Reset to replace the settings of the custom Default Scale List with the 

default software settings. 

 Click Export to save the scale list file with a different name. 

 Click Apply to save the scale list customization. 
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Note: You can redefine existing scale specifications in the Default Scale List. You can also 

reset the custom Drawing Scale List to the Default Scale List settings. 

7.2.9. Macro Recording 

You can record a series of commands in a script (also known as a macro) for automated 

execution. The parameters for macro recording are 

 Expand Location, in order to set the destination folder/locatino of the files generated 

by the recording. 

 Expand Level of Detail to set level of detail of the Macro (Low/High). 

 Expand Language to set the language on which the recording will be made ( C#, 

Native C++, JavaScript, VB.Net, C++ COM, VBA). 

7.3. User Preferences 

 

The User Preferences page of the Options dialog box lets you define: 

 Drafting Options 

 Mouse Options 

 Alias Commands 

7.3.1. Drafting Options 

You can use the DraftingOptions command to configure the drawing environment including 

EntitySnaps, snaps, grid display, EntityGrips, and entity selection. 
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 To set up drafting tools and preferences: 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Pointer Control, Display, Entity Selection, Dimension Palette, Heads-up 

Display, or other tree view items to set up drafting tools and preferences.  

7.3.2. Pointer Control 

 To set up EntitySnaps: 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Pointer Control > EntitySnaps.  

3. Select Enable EntitySnaps (ESnaps) to enable or disable the use of entity snaps.  

4. Select Geometry ESnaps and Reference ESnaps so you do not need to invoke 

them as you draw. (Should you need more information about ESnaps, see the topic 

«Understanding EntitySnap Modes» in the DraftSight Help files). 

 

 To set up snap options : 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Pointer Control > Snap Settings.  

3. Select Enable Snap to enable or disable snaps.  

4. Under Type, set:  

 Standard (snaps to grid): Causes the pointer to snap to points at specified 

horizontal and vertical spacings.  

 Radial (RSnap): Causes the pointer to snap to points along a radial vector. 

Polar guides must be on for this functionality to work.  

5. Under Spacing, set:  

 Match Grid spacing: Forces the pointer to snap along vertical or horizontal 

grid points when specifying points.  

 Horizontal Snap spacing: Sets the horizontal spacing of the snap grid.  

 Vertical Snap spacing: Sets the vertical spacing of the snap grid.  

 Match horizontal spacing: Transfers the value for horizontal spacing to the 

value for vertical spacing, so that grid display is evenly spaced in the X and Y 

directions.  

 RSnap spacing: Specifies the spacing when using the RadialSnap type.  

Note: You can customize snap and grid settings for each ViewTile. 
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7.3.3. Display 

 To set up EntityTrack guides : 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Display > ETrack and set :  

 Enable EntityTracking (ETrack): Displays orthogonal (horizontal and vertical) 
tracking guides when the pointer moves over EntitySnap points. (EntitySnap 
guides must be enabled).  

 Display ETrack guides across screen: Displays tracking guides. (EntitySnap 
guides must be enabled). When cleared, tracking paths display between the 
EntitySnap location and the pointer position. 

 Enable Shift to acquire reference points: Displays tracking guides when you 
hold down Shift and move the pointer over an EntitySnap point 
 

 To set up polar guides: 
1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 
expands. 

2. Expand Display > Polar guides.  
3. To enable polar guides, select Enable Polar guides (Polar). This option applies 

polar guide settings to EntitySnap pointers. The guides display along polar alignment 
angles from EntitySnap points (if ETrack is on).  

4. To display polar guides, select Display Polar guides. This option displays alignment 
paths.  

5. In Incremental angles for Polar guide display, select the angle increment to 
display and apply polar guides.  

6. Optionally, select or clear Display Polar guides at specific angle(s), and click: 

 Add  to specify individual values of angle increments for the use of polar 
guides. 

 Delete to remove specified individual values from the list. 

Note: (Should you need more information about the concept, see the topic «Using Polar 
Guides» in the DraftSight Help files). 

 To set up grid settings 
1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Display > Grid Settings:  

3. Select Enable Grid to enable or disable the display of a pattern of evenly spaced 

dots that serve as a visual distance reference.  

4. Under Orientation, set: 

 Rectangular: Orients the snap grid and grid display rectangularly. 

 Isometric: Orients the snap grid and grid display at a 60° angle. 

5. Under Spacing, set: 

 Match Snap spacing: Sets the grid spacing so that it matches the Snap 

settings . 

 Horizontal display spacing: Sets the horizontal spacing of the grid. 

 Vertical display spacing: Sets the vertical spacing of the grid. 
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 Match horizontal spacing: Transfers the value for horizontal spacing to the 

value for vertical spacing, so that grid display is evenly spaced in the X and Y 

directions. 

 

 To set up Pointer Cues 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Display > Pointer Cues and set: 

 Display ESnap cues: Displays ESnap markers when the pointer encounters 

ESnap points. The highlighting shows the ESnap mode you can apply. You 

can also set the cue color. 

 ESnap cue size: Sets the display size of ESnap markers. 

 

 To set up Gravity Box 

1. Type DraftingOptions at the command prompt.  

2. In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

3. Expand Display > Gravity Box and set: 

 Enable ESnap gravity: Pulls the pointer to an EntitySnap point when the 

pointer moves near the point. 

 Display GravityBox: Displays a box inside the crosshairs when you snap to 

an entity.  When snap points come within this box, they become 

candidates for ESnaps. Adjust the GravityBox size. 

7.3.4. Entity Selection 

 To set entity selection methods: 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Entity Selection > Selection Settings and set: 

 Automatic window/cross selection. Creates a selection window when you 

specify a point outside an entity. 

 Enable entity selection before commands. Lets you select entities first, 

then issue modifying commands on the selection set. If entities are not yet 

selected, you are prompted for entities. To clear the current selection set, 

press Esc. Pre-selection has no effect on Split, Trim, Extend, Chamfer, and 

Fillet commands. 

 Enable hatch/boundary relations. Selects Hatch entities and boundary 

entities when you select a related Hatch. 

 Enable EntityGroup selection sets. Selects all entities in an EntityGroup 

when you select one entity in that EntityGroup. 

 EntityGroup display mode. Controls which EntityGrips are displayed for an 

EntityGroup selection. 
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o All entities. Displays all EntityGrips on all entities of the specified 

EntityGroup. You can modify each entity using its EntityGrips. 

o Bounding box. Displays only one central EntityGrip for the entire 

EntityGroup, and a bounding box. 

o Egroup. Displays only one central EntityGrip for the entire 

EntityGroup. 

o SelectionBox size. Defines the display size of the SelectionBox (the 

pointer used to select entities). 

 To set entity selection highlighting 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Entity Selection > Pre-selected highlighting and set: 

 When prompted to specify entities or points. Previews selections when a 

command is active and prompts you to specify entities. 

 Between commands. Previews selections when no commands are active. 

 

 To set preview filter 
1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Entity Selection > Pre-selected highlighting and set: 

 When prompted to specify entities or points. Previews selections when a 

command is active and prompts you to specify entities. 

 Between commands. Previews selections when no commands are active. 

 To set preview filter 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Entity Selection > Preview filter.  

3. In Exclude, select the entity type to exclude from selection previews: 

 Entities on locked layers. Excludes entities on locked layers. 

 Notes. Excludes Notes. 

 References. Excludes entities in externally referenced drawings 

(References). 

 Hatches. Excludes Hatches and Gradients. 

 Tables. Excludes Tables. 

 Groups. Excludes entities in EntityGroups. 
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 To set EntityGrips (EGrips) Options 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Entity Selection > EGrips Options. 

3. In EGrips Options, set 

 Enable EntityGrips (EGrips). Displays EGrips for entities in the graphics 

area. 

 Enable EGrips in Blocks. Displays EGrips for each entity in a Block. 

 Enable EGrip tips. Displays tooltips at EGrips. 

 Set the EGrip display limit. Specifies a maximum number of entities 

displayed with EGrips at one time. If the number of specified entities exceeds 

the maximum (32,767), EntityGrips are disabled. 

 To set EntityGrips (EGrips) Colors 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Entity Selection > EGrips Colors. 

3. In EGrips Colors, set 

 Active EGrips: Sets the color of EGrips when you click on an EGrip. 

 Inactive EGrips: Sets the color of EGrips when you add an entity to a selection 

set with EGrips enabled. 

 Mouseover EGrips: Sets the color of EGrips when the pointer moves over an 

EGrip. 

 To set EntityGrips (EGrips) Size 

Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Entity Selection > EGrips Size. 

3. In EGrips Size, set the display size of EntityGrips. 

7.3.5. Dimension Palette (DraftSight Professional & Enterprise versions only) 

To set Dimension palette preferences: 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting 

Options expands. 

2. Expand Dimension Palette.  

3. Click Enable Dimension palette to turn on or off the Dimension palette.  

4. In Favorites library path, set the path for Dimension text favorites files 

(*.dimfvt files). Click Browse to browse for the Dimension text favorites file 

folder. 
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7.3.6. Heads-Up Display (DraftSight Professional & Enterprise versions only) 

 To show or hide the Heads-up Display toolbar: 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand Heads-Up Display.  

3. Select or clear Enable Heads-up toolbar. When selected, the toolbar displays when 

you select entities.  

7.3.7. OLE Editor 

 To set OLE Editor options: 

1. Type DraftingOptions at the command prompt.  

In the Options dialog box, the User Preferences page opens and Drafting Options 

expands. 

2. Expand OLE Editor.  

3. Select or clear Use in-place editor to specify whether to edit Object Linking and 

Embedding (OLE) objects inside or outside the drawing.  

7.3.8. Mouse Options 

 To set Mouse Options: 

1. Do one of the following : 
 Click Tools > Options (or type Options). 

In the Options dialog box, click User Preferences . 

 Type UserPreferences.  
2. Expand Mouse Options.  
3. Expand Options to set:  

 Reverse the zoom wheel direction. Changes the zoom direction of the 
mouse wheel.  

 Enable Click and drag. Lets you draw selection windows or use the 
Crossing method by clicking a point (and holding down the mouse button) and 
dragging the pointer to a second point. When cleared, you can draw selection 
windows or use the Crossing method by clicking two separate points.  

 Edit by double-clicking. Enables double-click editing behavior in the 
graphics area.  

 Display shortcut menus by right-clicking. Displays the context-sensitive 
shortcut menu when you right-click in the graphics area.  
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7.3.9. Fast Enter Behavior 

Expand Fast Enter behavior to set Enable Enter on fast right-click. This executes Enter 

when you click in the time set for Fast click time. Click longer to display a context-sensitive 

shortcut menu. 

7.3.10. Currently processing other command 

Expand Currently processing other command to set right-click behavior when running 

commands:  

 Displays the shortcut menu  

 Displays the shortcut menu only if command options are available  

 Is the same as pressing Enter (for example, to accept a command's option or to 

terminate a command) 

7.3.11. Selected entities 

Expand Selected Entities to set right-click behavior when entities are selected and no 

command is active:  

 Displays the shortcut menu  

 Repeats the last command 

7.3.12. Unselected entities 

Expand Unselected Entities to set right-click behavior when no entities are selected and no 

command is active: 

 Displays the shortcut menu  

 Repeats the last command 

7.3.13. Aliases 

 To create and manage Aliases 

1. Do one of the following : 

 Click Tools > Options (or type Options). 

In the Options dialog box, click User Preferences. 

 Type UserPreferences. 

2. Expand Aliases to manage keyboard shortcuts.  

Examples for alias commands include L for Line, C for Circle, or A for Arc. 

3. Use the following options: 

 New. Creates a new keyboard shortcut in the alias list. An entry is added to 

the list where you can type the command representing the keyboard shortcut 

and the alias name. 

 Delete. Removes the selected keyboard shortcut from the alias list. 

 Import. Imports an alias file (.xml, .ica, or .pgp files). 

 Export. Writes an .xml file to save the alias settings. 
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7.4. Drawing Settings 
The Drawing Settings page of the Options dialog box lets you set the behavior of certain 

drawing commands, the appearance of certain drawing entities, the unit system of the 

current drawing, manage Custom Coordinate Systems (CCSs), customize the Drawing 

Scale List, and set up drawing standards verification. 

 

 To set the behavior of certain drawing commands and set line scale options: 

1. Do one of the following : 

 Click Tools > Options (or type Options). 

In the Options dialog box, click Drawing Settings 

 Type DrawingSettings. 

7.4.1. Behavior 

Expand Behavior and select or clear Enable relative dimensions. This specifies that 

dimensions you create are associated to the measured entities. 
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7.4.2. LineStyle Parameters 

Expand LineStyle Parameters and set: 

 Global line scale. Sets a scale factor for displaying LineStyles. (This is 

helpful when zooming in and out). 

 Line scale for new entities. Sets the entity line scale for new entities. All 

entity line scales are displayed based on multiplying the Global line scale by 

the entity line scale. 

 Scale based on sheet's units. Multiplies the Viewport's custom scale by the 

evaluated value for Line scale for new entities. 

7.4.3. Drawing Boundary 

Expand Drawing Boundary and set: 

 Enable drawing boundary. Restricts you to drawing entities within the boundary set 

in Position. 

 Position. Sets the drawing boundary borders. Specify the coordinates or click Select 

in graphics area to set the boundaries in the graphics area. 

7.4.4. Entity frame control 

Expand Entity Frame Control. This allows you to set the frame visibility for Images, OLE 

objects, PDF and DGN Underlay. 

 Do not display and print frame. Hides the frame at the borders of entity in the 

graphics area and on printouts. 

 Display but do not print frame. Shows the frame at the borders of entity in the 

graphics area, but hides it on printouts. 

 Display and print frame. Shows the frame at the borders of entity in the graphics 

area and on printouts. 

7.4.5. Display options 

 To set Display Options 

1. Do one of the following : 

 Click Tools > Options (or type Options). 

In the Options dialog box, click Drawing Settings 

 Type DrawingSettings. 

2. Expand Display and set: 

 Show Model and Sheet tabs: Turns on and off the display of the 

Model and Sheet tabs.  

 Show block attributes: 

o Normal. Uses the setting defined in the BlockAttribute.  

o On. Shows BlockAttributes regardless of the setting defined in 

the BlockAttribute and regardless if they are hidden. 

o Off. Hides BlockAttributes. 
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7.4.6. Coordinate System Icon 

 Expand Coordinate System Icon and set: 

 Display icons. Displays coordinate system icons in the Model and Sheet tabs.  

 Display icons at origin. Always displays coordinate system icons at the origin 

location in the graphics area. 

 Apply changes to all actively displayed views. Applies the settings for Display 

icons and Display icons at origin to all views. 

7.4.7. Thumbnail 

 Expand Thumbnail and specify when thumbnail previews are updated: 

 Model space views. Updates thumbnail previews for Model views.  

 Sheet views. Updates thumbnail previews for layout Sheet views.  

 Sheets. Updates thumbnail previews for layout Sheets.  

 Sheets or views created, modified or restored. Updates thumbnail 

previews when layout Sheets or views are created, modified, or restored.  

 When drawing is saved. Updates thumbnail previews when the drawing is 

saved.  

If you clear all options, thumbnail previews are not updated. 

7.4.8. Points – Point format 

You can set the display format and size of points. Although mathematically points have no 

size, you can specify the display size. 

When you use the Point command the appearance of the points depends on the settings for 

the point format. 

 

 To set the point format: 

1. Click Format > Point Style (or type PointFormat).  

In the Options dialog box, the Drawings Settings page opens and Points 

expands. 

2. In Type, select the display format. 

3. For Size, type a value. 

4. Select a size option : 

 Absolute units. Point size is set in a value of drawing units. 

 % Relative to display. Point size is a percentage of the visible 

drawing plane. 



DraftSight - Configuration & Basic Customization 

55 

 

3
D

S
.C

O
M

 ©
 D

a
s
s
a

u
lt
 S

y
s
tè

m
e

s
  

| 
 C

o
n

fi
d
e

n
ti
a

l 
In

fo
rm

a
ti
o

n
  

| 
 0

1
/0

2
/2

0
1

2
  
re

f.
: 

D
o
c
u

m
e

n
t_

R
e
fe

re
n

c
e

 |
 

7.4.9. Unit System 

 

The UnitSystem command lets you set: 

 Formats for linear and angular units  

 Accuracy levels by specifying the number of decimal places  

 The reference unit of measurement for Blocks and drawings in the drawing  

You can set the linear and angular unit formats and precision independently. 

The unit settings are saved with each drawing, and so they can be different for each 

drawing. 

 To specify units and precision : 

1. Click Format > Unit System (or type UnitSystem).  

In the Options dialog box, the Drawing Settings page opens and Unit System 

expands. 

2. Under Base angle : 

 Set the base angle that specifies a direction for 0°. For example, surveyors 

normally set 0° as "up" on the page. This setting ensures the correct display 

of angle and distance for drawing lines; the display on the status bar updates 

according to the angle zero direction and the orientation. 

 Select Clockwise to increase angles in a clockwise direction. 

 Set the rotation angle, or click Select in graphics area  to set the rotation 

angle and second point in the graphics area. 
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3. Under Length, set the: 

 Type of linear units. 

 Precision from 0 to 8 decimal places. 

The selected units are displayed in the Preview area. 

Examples of linear units: 

 

4. Under Angle, set the: 

 Type of angular units. 

 Precision from 0 to 8 decimal places. 

The selected units are displayed in the Preview area. 

Examples of angular units: 

 

5. Under Units scale, in Block units format, select the reference unit of measurement 

for Blocks and drawings in the drawing. Select Unitless to prevent scaling of entities. 

If the units of a Block (or drawing) to be inserted differ from the units in Block units 

format, the Block is scaled. This insertion scale determines the ratio between the 

units in the source and the units in the target drawing. 

7.4.10. Coordinate System 

Use the CSStyle command to manage coordinate systems. You can: 

 Manage coordinate systems by viewing, activating, renaming, or deleting them 

 Select an orthographic coordinate system 

 Adjust coordinate system settings 

To create a named Custom Coordinate Systems, use the CCS command. 
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 To view saved coordinate systems: 

1. Click Tools > CCS Manager (or type CSStyle).  

In the Options dialog box, the Drawing Settings page opens and Coordinate 

System expands. 

2. Expand Named. 

3. Hover the pointer over a coordinate system to view the origin and X, Y, and Z 

coordinates. 

 

 To activate a coordinate system: 

1. Click Tools > CCS Manager (or type CSStyle).  

In the Options dialog box, the Drawing Settings page opens and Coordinate 

System expands. 

2. Expand Named. 

3. Select a coordinate system and click Activate. 

A  displays beside the active coordinate system. 

 

 To delete or rename a coordinate system: 

1. Click Tools > CCS Manager (or type CSStyle).  

In the Options dialog box, the Drawing Settings page opens and Coordinate 

System expands. 

2. Expand Named. 

3. Select a coordinate system and click Delete or Rename.  

You can use Rename to name an unnamed coordinate system. You cannot delete or 

rename the World Coordinate System (WCS). 

 

 To set a temporary orthographic coordinate system on a face of a cube: 

1. Click Tools > CCS Manager (or type CSStyle).  

In the Options dialog box, the Drawing Settings page opens and Coordinate 

System expands.  

2. Expand Defaults.  

3. Select a face (Top, Bottom, Front, Back, Left, or Right) and click Activate.  

4. In Relative to, select the coordinate system to which the temporary coordinate 

system should be relative. 

 

 To set up coordinate systems: 

1. Click Tools > CCS Manager (or type CSStyle).  

In the Options dialog box, the Drawing Settings page opens and Coordinate 

System expands.  

2. Expand Options.  

3. Set options: 

 Update view when coordinate system changes: Automatically displays the 

plan view to the coordinate system in the active ViewTile when the coordinate 

system changes. 

 Save coordinate system with view configurations: Forces all ViewTiles to 

reflect its active coordinate system. Otherwise, the coordinate systems of 

other ViewTiles remain unchanged. 
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 To set up the coordinate system icon: 

1. Click Tools > Options (or type Options).  

2. In the Options dialog box, click Drawing Settings  

3. Expand Display > Coordinate System Icon. 

4. Set options: 

 Display icons: Displays the coordinate system icon.  

 Display icons at origin: Displays the coordinate system icon at the origin 

(0,0,0) of the active coordinate system. If the origin is off the display, the 

coordinate system icon displays in the lower left of the view.  

 Apply changes to all actively displayed views: Determines whether the 

coordinate system icon settings apply to all active views or only the active 

one. 

7.4.11. Drawing Scale List: 

Use the EditScaleList command to customize the list of scales for printing, managing Print 

Configurations, scaling Viewports on layout Sheets, and assigning scales to annotative 

entities. 

This scale list is stored and valid for the current drawing. It is named Drawing Scale List. 

You can also customize the Default Scale List, which determines the Drawing Scale List for 

new drawings, which are created without template drawings. 

 To Customize the Drawing Scale List: 

1. Click Tools > Options (or type Options).  

In the Options dialog box, click Drawing Settings .  

or 

Type EditScaleList at the command prompt. 

2. Expand Drawing Scale List. 

3. Click Add to add a new scale to the list: 

a. In the Scale Name column of the new list item, type a descriptive name for 

the new scale, typically the ratio from paper units to drawing units. 

b. In Paper Units, type a number. 

c. In Drawing Units, type a number.  

The ratio between between paper units and drawing units determines the 

scale applied when selecting the scale name in the scale list. 

3. Click Move up to move the selected item up in the list. 

4. Click Move down to move the selected item down in the list. 

5. Click Delete to remove the selected item from the list. You cannot delete named 

scales that are used in the drawing. 

6. Click Reset to replace the settings of the custom Drawing Scale List with the settings 

of the Default Scale List. 

7. Click Apply to save the scale list customization. 

Note : You can also redefine existing scale specifications in the Drawing Scale List. You 

cannot delete or modify scales that are referenced by entities in the drawing or that are 

referenced by References. 
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7.4.12. Standards configuration 

Use the DrawingStandards command to: 

 Associate drawing standards to the current drawing  

 Determine the drawing categories to check  

 Set notification and audit options 

 

 To associate drawing standards to the current drawing: 

1. Click Tools > Standards > Drawing Standards (or type DrawingStandards). 

2. In the dialog box, expand Standards. 

3. Click New. 

4. In the file dialog box, specify the name for the drawing standard file (*.dws) to 

associate to the current drawing. 

5. Click Open. 

6. Optionally, repeat steps 2 and 3 to add more standards files to the list.  

Click Delete to remove a standard from the list.  

Standards from multiple standards files are checked in the order specified in the list. 

To change the priority, select an item, then click Move up or Move down.  

Under Settings, read information about the selected standard including drawing file 

name, drawing format (release version), last modification date, and who did the last 

change. 

7. Click Verify Standards to verify the associated standards immediately. This option 

runs the VerifyStandards command. 

8. Click Apply. 

 

 To determine the drawing categories to check: 

1. Click Tools > Standards > Drawing Standards (or type DrawingStandards).  

2. In the dialog box, expand Drawing Categories.  

3. Activate the drawing categories to include for verification with the VerifyStandards 

command: 

 Layers 

 LineStyles 

 DimensionStyles 

 TextStyles 

Note : Check at least one category to enable drawing standards checks. 

4. Click Apply. 

 

 To set notification and audit options: 

1. Click Tools > Standards > Drawing Standards (or type DrawingStandards). 

2. In the dialog box, expand Options. 

3. In Notification, select an option: 

 Disable alert message: Turns off standards violation notifications. 

 Pop-up alert over standards violation: Displays a pop-up alert when 

standards violations are detected in the current drawing (default). 

4. In Verify standards, specify options: 
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 Automatically fix nonstandard properties: Specifies whether to 

automatically fix nonstandard objects when you run the VerifyStandards 

command (cleared by default). 

 Show ignored standard violations: Specifies whether to display standards 

violations that are flagged as ignored in the Verify Standards dialog box 

(selected by default). 

 Preferred standard file: Sets a drawing standards file (*.dws) or None. 

5. Click Apply. 

 

Note : As many users are not familiar with the VerifyStandards command, below you’ll find 

more information about the command/functionality available. 

Verifying Drawing Standards 
 

Use the VerifyStandards command to check that the current drawing conforms to industry, 

corporate, and custom standards. 

The command checks whether names and properties of Layers, LineStyles, 

DimensionStyles, and TextStyles in the current drawing match those in associated standards 

files. 

You can replace nonstandard items to be compliant, flag them to be ignored, or leave them 

as they are. 

It is recommended to run the Clean command to purge unused objects before you run the 

VerifyStandards command. 

 To verify drawing standards 

1. Click Tools > Standards > Verify Standards (or type VerifyStandards).  

In the dialog box, the category and name of an item that violates drawing standards 

are shown (for example DimensionStyle as category and the name of a 

DimensionStyle).  

2. In Replace with, select a drawing standard.  

The list may contain more than one standard because the drawing standards file may 

contain more than one object per category, or the list of drawing standards files 

defined for the current drawing contains more than one file.  

In Preview of changes, the differences between the current item verified for 

compliance and the standard selected in the replacement list are displayed. This list 

is empty if the item name differs, but not the properties.  

3. Optionally, set Ignore this standards violation to flag the current item as not to be 

replaced. The Ignored by information shows the login name of the user who set the 

ignore option. This status is stored with the drawing.  

4. Click Fix to accept the replacement of the current item by the specified drawing 

standard.  

5. Click Next to proceed to the next item.  

6. Repeat steps 2 through 5 for subsequent items to check for standards compliance.  
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7. Click Close.  

8. At the end of the verification process, a summary screen reports the total number of 

standards violations, the number of automatically fixed items, the number of manually 

fixed items, and the number of items that have been marked as "ignored." 

7.4.13. Dimension Snap Offset Distances (Professional & Enterprise 

versions only): 

You can force dimension lines to be placed at specified distances from measured linear 

entities and between successive dimension lines or at specified angles for radius and 

diameter dimensions. 

1. Do one of the following:  

 Click Tools > Options (or type Options). 

In the Options dialog box, click Drawing Settings . 

 Type DrawingSettings.  

2. Expand Dimension Snap Offset Distances.  

3. Specify whether to Enable offset distances.  

4. Under Offset Distances, set the:  

 Offset of the first dimension line from a measured linear entity.  

 Offset distance between successive dimension lines. 

 
The default offset distances are 0.40 inches (or 10 mm) between the entity and first 

dimension line and 0.25 inches (or 6 mm) between dimensions. 

5. In Radial/diameter snap angle, set the snap angle intervals to use when you drag 

radius and diameter dimensions along radial locations. The default snap angle is 15°. 

6. Under Bounding Box, set 

 Enable dimension bounding box. Enables the use of tools for working with 

dimension bounding boxes. The corresponding options are available in the 

context menu. 

 Show dimension bounding box. Displays all bounding boxes in the drawing. 

7.4.14. Centerlines Settings (Professional & Enterprise versions only) 

 To set preferences for Centerlines  

1. Do one of the following:  

 Click Tools > Options (or type Options). 

In the Options dialog box, click Drawing Settings. 

 Type DrawingSettings.  

2. Expand Centerlines.  

3. In Extension, specify the extension for Centerlines to exceed the entities which 

define the contour.  



DraftSight - Configuration & Basic Customization 

62 

 

3
D

S
.C

O
M

 ©
 D

a
s
s
a

u
lt
 S

y
s
tè

m
e

s
  

| 
 C

o
n

fi
d
e

n
ti
a

l 
In

fo
rm

a
ti
o

n
  

| 
 0

1
/0

2
/2

0
1

2
  
re

f.
: 

D
o
c
u

m
e

n
t_

R
e
fe

re
n

c
e

 |
 

7.4.15. Arrow Key Movement (Professional & Enterprise versions only) 

 To set preferences for Arrow Key Movement 

1. Do one of the following:  

 Click Tools > Options (or type Options). 

In the Options dialog box, click Drawing Settings. 

 Type DrawingSettings.  

2. Expand Arrow Key Movement and set 

 Arrow Key Increment. Specifies a positive value to move entities using the 

arrow keys. Specifies the distance that the selected entities move (Shift + 

Arrow key). For example, if you set Arrow Key Increment to 2.5, pressing 

Shift + Arrow once moves the selected entities 2.5 units orthogonally, in the 

arrow direction. 

 Page up/down increment. Specifies a multiplication factor for the Arrow Key 

Increment. For example, if you set Arrow key increment to 2.5 and Page 

up/down increment to 2, pressing Shift + Arrow key once moves the 

selected entities 5 units orthogonally, in the arrow direction. 

7.5. Drafting Styles 
The Drafting Styles page of the Options dialog box lets you manage TextStyles, 

DimensionStyles, RichLineStyles, and TableStyles. In addition you can set a style for 

use with subsequent commands. 
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 To access the Drafting Styles page of the Options dialog box: 

Do one of the following: 

 Click Tools > Options (or type Options).  

In the Options dialog box, click Drafting Styles .  

 Type DraftingStyles. 

7.5.1. Setting Active Drafting Styles 

Use the Styles command to activate a drafting style for use with subsequent commands. 

Drafting styles include TextStyles, DimensionStyles, RichLineStyles, TableStyles, Layers, 

and line fonts (LineStyles, LineColors, and LineWeights). 

 To set a drafting style as active : 

1. Type Styles at the command prompt.  

In the Options dialog box, the Drafting Styles page opens and Active Drafting 

Styles expands. 

2. Expand a style: 

 Text. Sets the active TextStyle for new text entities created with the Note or 

SimpleNote command. 

 Dimension. Sets the active DimensionStyle for new Dimensions created with 

the dimensioning commands. 

 RichLine. Sets the active RichLineStyle for new RichLine entities created 

with the RichLine command. 

 Table. Sets the active TableStyle for new Tables created with the Table 

command. 

 Layer. Sets the active Layer for new entities. 

 Line Font. Sets the active: 

 LineStyle 

 LineColor 

 LineWeight 

3. Double-click an item to activate it. 

A  appears before the item to indicate that it is activated. 

 

An  in front of a TextStyle or DimensionStyle name indicates that you can apply 

this style for annotative scaling of Notes, SimpleNotes, and Dimensions. 

4. Click OK. 

7.5.2. To Manage TextStyles  

Use the TextStyle command to create, edit, activate, or delete TextStyles in drawings. 

When you add Notes or SimpleNotes to a drawing, it uses the active TextStyle. A TextStyle 

is defined by font, type face characteristics, size, and other properties. 

You can use TrueType fonts or compiled shape fonts (of type .shx). 



DraftSight - Configuration & Basic Customization 

64 

 

3
D

S
.C

O
M

 ©
 D

a
s
s
a

u
lt
 S

y
s
tè

m
e

s
  

| 
 C

o
n

fi
d
e

n
ti
a

l 
In

fo
rm

a
ti
o

n
  

| 
 0

1
/0

2
/2

0
1

2
  
re

f.
: 

D
o
c
u

m
e

n
t_

R
e
fe

re
n

c
e

 |
 

The TextStyle command loads fonts from files and customizes them to the drawing 

requirements. 

You can define TextStyles to apply annotative scaling for Notes and SimpleNotes. 

 To create TextStyles: 

1. Click Format > Text Style (or type TextStyle).  

In the Options dialog box, the Drafting Styles page opens and Text expands. 

2. Click New.  

3. In the Create new TextStyle dialog box, type a new name and click OK.  

The new TextStyle appears in Style. 

4. Under Text, set:  

 Font. Lists all installed TrueType fonts provided with your operating system by 

font family name. Fonts of type .shx are listed by the name of the file where they 

are stored.  

 Format. Lists formats you can apply to the font (Normal, Italic, Bold, Bold Italic, 

for example, for TrueType fonts). While creating a TextStyle, the command 

displays a default font style dependent on the selected font name. When you 

make changes to the default name in Style, a new default name is no longer 

suggested and your changes become the new default.  

 Big font. Lists all files that have big fonts which are stored in .shx files.  

5. Under Height, set:  

 Annotative Scaling. Specifies whether annotative scaling is used for Notes and 

SimpleNotes which apply the TextStyle you define. In Style, annotative 

TextStyles are marked with an .  

 Match text orientation to Sheet. Specifies whether the orientation of Notes and 

SimpleNotes in Viewports of layout Sheets follows the Sheet orientation. This 

option is available only if you selected annotative scaling. 

 Height or Sheet text height. Sets the TextStyle height in drawing units.  

o Height. If the TextStyle is not defined for annotative scaling: A numeric 

value sets the font at a fixed height that you cannot change when 

inserting a Text entity that uses the selected Font. Set Height to 0.0 if you 

need to change the TextStyle height.  

 Sheet text height. If the TextStyle is defined for annotative scaling: A 

numeric value sets the font at a fixed height that you cannot change when 

inserting a Text entity that uses the selected Font. Set Height to 0.0 if you 

need to change the TextStyle height.  

6. Under Orientation, set:  

 Backwards. Displays a mirror-image of the text. Applies to SimpleNotes, 

not Notes.  

 Upside down. Displays text upside down. Applies to SimpleNotes, not 

Notes.  

 Vertical. Aligns the text vertically. Applies to SimpleNotes, not Notes. This 

option is available only for *.shx font files that support dual orientation.  
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 Angle. Defines the inclination of the characters in relation to a horizontal 

(X-axis) line. Values between 0 and 84.90 result in an inclination to the 

right (forward), values between 0 and -84.9 result in an inclination to the 

left (backward).  

 Spacing. Controls the width of the characters in relation to the height. 

This relation is called the aspect ratio.  

You can combine these settings, although in some cases the combination of 

properties can interfere with each other. Some fonts do not support all 

options. 

Note : The Preview area displays the TextStyle you define with the specified font and 

parameters. You can edit the Preview text. 

 To edit TexStyles : 

When you edit TextStyles, all existing Text entities that use the TextStyle automatically 

update to reflect the modified style. 

1. Click Format > Text Style (or type TextStyle).  

In the Options dialog box, the Drafting Styles page opens and Text expands. 

2. In Style, select a TextStyle.  

The Style list contains all TextStyles that are defined in the drawing. You cannot 

change the name of the Standard TextStyle, but you can edit its settings. 

3. Set options under Text and Orientation. 

 

 To activate a TextStyle : 

The active TextStyle is used for the Note and SimpleNote commands. 

1. Click Format > Text Style (or type TextStyle).  

In the Options dialog box, the Drafting Styles page opens and Text expands. 

2. In Style, select a TextStyle.  

3. Click Activate. 

 

 To rename TextStyles : 

1. Select Format > Text Style (or type TextStyle).  

In the Options dialog box, the Drafting Styles page opens and Text expands. 

2. In Style, select a TextStyle.  

3. Click Rename.  

4. Type a new name in the Rename TextStyle dialog box and click OK. 

 

 To delete TextStyles : 

1. Select Format > Text Style (or type TextStyle).  

In the Options dialog box, the Drafting Styles page opens and Text expands. 

2. In Style, select a TextStyle.  

3. Click Delete.  
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Note : You cannot delete a TextStyle that is currently used in the drawing. 

TIP : TextStyles are saved with the drawing file only with a reference to the corresponding 

font file. They are available any time you open the drawing if the corresponding font file 

exists in the program folders..  

7.5.3. Dimension Styles 

Use the DimensionStyle command to create and modify DimensionStyles. 

DimensionStyles control the way Dimensions look. 

You can define DimensionStyles to apply annotative scaling for Dimensions. 

 

 To create a new Dimension Style : 

1. Select Format > Dimension Style (or type DimensionStyle).  

In the Options dialog box, the Drafting Styles page opens and Dimension 

expands. 

2. Click New.  

3. In the Create new DimensionStyle dialog box :  

a. For Name, type a value. 

b. In Based on, select an existing DimensionStyle. This style serves as the 

base settings for the new DimensionStyle. 

c. In Apply to, select a Dimension type. This specifies that the new 

DimensionStyle is valid for all Dimensions or for a specific type of 

dimensioning. 

d. Click OK. 

4. Under Dimension, set up the DimensionStyle. (See DimensionStyle Settings below). 

5. Click OK. 
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 To modify a DimensionStyle : 

1. Click Format > Dimension Style (or type DimensionStyle).  

In the Options dialog box, the Drafting Styles page opens and Dimension 

expands. 

2. In Style, select a DimensionStyle to modify.  

3. Under Dimension, set up the DimensionStyle. See DimensionStyle Settings below.  

4. Click Activate or OK. 

 

 To set the active DimensionStyle : 

1. Click Format > Dimension Style (or type DimensionStyle).  

In the Options dialog box, the Drafting Styles page opens and Dimension 

expands. 

2. In Style, select a DimensionStyle to activate.  

3. Click Activate. An  displays beside the active DimensionStyle. 

4. Click OK. 

 

 To compare DimensionStyles : 

1. Click Format > Dimension Style (or type DimensionStyle).  

In the Options dialog box, the Drafting Styles page opens and Dimension 

expands. 

2. Click Differences.  

3. In the Find Differences in DimensionStyles dialog box, in Compare and To, select 

a DimensionStyle. The DimensionStyle settings that differ are listed in the dialog box. 

4. Click Copy to copy the differences, or click Close.  

5. Click Close. 

 

 To override DimensionStyle settings : 

You can temporarily change settings of the active DimensionStyle. These changes do 

not modify the DimensionStyle settings. The overriding settings can be applied as long 

as no other DimensionStyle is set as active. 

1. Click Format > Dimension Style (or type DimensionStyle).  

In the Options dialog box, the Drafting Styles page opens and Dimension 

expands. 

2. In Style, select a DimensionStyle to override.  

3. Click Activate.  

4. Click Set Overrides.  

5. Set DimensionStyle overrides. See DimensionStyle Settings below.  

6. Click OK. 
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 To rename a DimensionStyle : 

1. Click Format > Dimension Style (or type DimensionStyle).  

In the Options dialog box, the Drafting Styles page opens and Dimension 

expands. 

2. In Style, select a DimensionStyle to rename.  

3. Click Rename.  

4. In the Rename DimensionStyle dialog box specify a new name for the selected 

DimensionStyle and click OK. 

 

 To delete a DimensionStyle : 

1. Click Format > Dimension Style (or type DimensionStyle).  

In the Options dialog box, the Drafting Styles page opens and Dimension expands. 

2. In Style, select a DimensionStyle to delete.  

3. Click Delete.  

Confirm the deletion of the selected DimensionStyle. You cannot delete the 

DimensionStyle named Standard or DimensionStyles referenced in the drawing by 

Dimension entities. 

TIP : You can remove DimensionStyles that are not referenced in the drawing with the Clean 

command. 

7.5.4. DimensionStyle Settings 

 Angular Dimension 

Angular Dimension settings 
 Format: Sets the primary angular units format (Decimal Degrees, Deg/Min/Sec, 

Grads, or Radians). 

 Precision: Sets the number of decimal places. 

 Zeroes display: Lets you suppress leading and trailing zeroes in angular 

Dimensions. 

Arc length symbols 
Lets you set the display of a symbol for arc length Dimensions: Before dimension text, 

Above dimension text, or None. 

Arrows 
 Start arrow: Specifies the Dimension's starting arrowhead.  

 End arrow: Specifies the Dimension's ending arrowhead.  

 Leader arrow: Sets the Dimension's leader arrow style.  

 Size: Sets the arrowhead size. 
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Dual Dimension 
These options control the use of a second, alternative dimensioning method. This mode 

allows dual dimensioning in metric and imperial values. 

Show dual dimensions: Determines whether to use alternate units in Dimensions. 

Dual dimension settings 
 Format: Sets the alternate unit format.  

 Precision: Sets the number of decimal places.  

 Multiplier for converting units: Sets a multiplier for converting units.  

 Round to the nearest: Lets you specify a value for rounding.  

 Prefix and Suffix: Lets you specify a prefix and suffix for the Dimension value. 

Zeroes display 
 Hide leading zeroes and Hide trailing zeroes: Lets you suppress leading and 

trailing zeroes.  

 Hide if 0' and Hide if 0": If you set Format to Architectural, Architectural Stacked, 

or Engineering, you can also specify whether to hide zero feet and zero inches. 

Insertion 
 After primary units and Below primary units: Specifies whether alternate units are 

placed after or below the primary Dimension value. 

Fit 
Fit options determine how to arrange Dimensions if there is not enough space for text and 

arrows between the extension lines. 

Geometry 
 When space is limited, move selected entity outside of extension lines: When 

there is not enough room to place text and arrows inside the extension lines, the first 

entity to move outside the extension lines is:  

o Automatic: Either text or arrows (best fit)  

o Arrows  

o Text  

o Text and arrows  

o Keep text between extension lines  

 Hide arrows: Suppresses arrows if they do not fit inside the extension lines. 

Dimansion text 
 When dimension text is not in the default position, move it: When Dimension 

text is not in the default position, you can place it:  

o Above the dimension line with leader  

o Above the dimension line without leader  

o Next to the dimension line 
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Dimension scale 
 Annotative Scaling: Specifies whether annotative scaling is used for Dimensions 

which apply the DimensionStyle you define. In Style, annotative DimensionStyles are 

marked with an  icon.  

 Scale factor: Specifies the overall scale for DimensionStyle settings. The scale 

factor influences size, distance, and spacing, including text and arrowhead sizes.  

This option is available only if you selected annotative scaling for the DimensionStyle. 

 Scale dimensions according to sheet: Sets a scale factor based on the ratio 

between the current Viewport and the drawing Sheet.  

This option is available only if you selected annotative scaling for the DimensionStyle. 

Additional options 

 Dimension lines between extension lines: Forces dimension lines to remain 

between the extension lines, even if the arrowheads are generated outside the 

Dimension.  

 Specify text placement: Lets you position Dimension text manually; horizontal 

justification settings are ignored. 

Linear Dimension 
 Format: Sets the primary linear units format. 

 Precision: Sets the number of decimal places. 

 Fractional display: Sets the stack display of fractional units. 

 Decimal separator: Sets the decimal separator for Dimensions whose unit Format is 

set to Decimal. 

 Round to the nearest: Lets you specify a value for rounding. 

 Prefix and Suffix: Lets you type a character string to appear before or after the 

Dimension text. For example, the suffix field can display the unit of measurement. 

Measurement scale 

 Scale factor: Forces all linear Dimension texts (including the Dimension text of 

diameters, radii, and coordinates) to be multiplied with the specified scale factor. 

Angular Dimensions and the plus-/minus values of Tolerances are not affected. The 

setting applies especially for non-associative dimensioning (for example, when you 

dimension scaled details).  

 Follow sheet dimensions: Applies the measurement scale factor to Dimensions 

created on Sheets only. 

Zeroes display 

 Hide leading zeroes and Hide trailing zeroes: Lets you suppress leading and 

trailing zeroes in decimal linear Dimensions.  

 Hide if 0' and Hide if 0": If you set Format to Architectural or Engineering, you 

can also specify whether to hide zero feet (Hide if 0') and zero inches (Hide if 0") 
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Line 

Dimension line settings 
 Style: Sets the Dimension line LineStyle.  

 Weight: Sets the Dimension line LineWeight.  

 Color: Sets the Dimension line LineColor.  

 Offset: Sets the offset distance of Dimension lines when baseline dimensioning is 

applied using the BaselineDimension command.  

 Distance past start arrow: Sets a distance to extend the Dimension line beyond the 

extension line when you apply certain arrowheads such as tick or architectural.  

 Hide: 

o Dimension line 1: Determines whether the first Dimension line and 

arrowhead between the first extension line and the Dimension text is 

displayed.  

o Dimension line 2: Has the same effect as Dimension line 1 for the second 

extension line and Dimension text. 

Extension line settings 
Extension lines are the lines that extend the Dimension outside the perimeter of the 

measured entity, assuming that dimensioning is to take place outside of these perimeter 

constraints. 

 Styles: Sets the LineStyle for Extension line 1 and Extension line 2.  

 Weight: Sets the extension line LineWeight.  

 Color: Sets the extension line LineColor.  

 Offset: Sets the offset distance between the entity and the point where extension 

lines begin.  

 Distance past dimension lines: Sets the distance the extension lines should run 

past the Dimension lines.  

 Hide: Hides the first and/or second extension line.  

 Fixed length: Specifies whether extension lines should have a preset length. Set a 

value in Length.  

 

Dimension split (Professional & Enterprise versions only) 
 Split gap. Specifies the width of the default gap when you use the SplitDimension 

command to split dimension and extension lines which cross other entities. 

Radial/Diameter Dimension 

Center mark display 
 None, As mark, As centerline: Defines the display of marks that indicate a Circle's 

center point and defines whether or not dashes or strokes should be added to center 

marks.  

 Size: Lets you specify the size of center marks for center, diameter, and radius 

Dimensions.  
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Radius dimension jog 
 Angle: Determines the angle of the transverse segment of the dimension line in a 

jogged radius Dimension. 

Text 

Text settings 

 Style: Sets the Dimension TextStyle. Click   to define TextStyles.  

 Color: Sets the Dimension TextColor.  

 Fill: Sets the Dimension text background color.  

 Height: Sets the Dimension text height.  

 Fractional scale: Sets a scale factor for the text height of tolerance values relative to 

the general Dimension text height.  

 Frame dimension text: Draws a frame around Dimension text.  

Text position 
 Horizontal and Vertical: Sets the horizontal and vertical positions of the Dimension 

text.  

 Offset from dimension lines: Sets the distance that text is offset from the 

Dimension lines.  

Text alignment 
You can align the Dimension text with the following options: 

 Use ISO standard  

 Align horizontally  

 Align with dimension lines 

Tolerance 

Tolerance settings 
 Calculation: Sets the format for tolerance creation:  

o Basic. Displays the additional Dimension measurement and deviation in a 

single value with a box around it.  

o Deviation. Appends separate plus and minus values of deviation to the 

Dimension measurement.  

o Limits. Displays a maximum and a minimum value, one on top of the other.  

o None. Does not generate a tolerance value.  

o Symmetrical. Appends a plus/minus tolerance value to the Dimension 

measurement which indicates the positive and negative deviation in a single 

value.  

 Precision: Sets the number of decimal places.  

 Maximum value and Minimum value: Sets values for the positive or negative 

tolerances.  

 Scale: Sets the tolerance scale.  
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 Vertical text justification: Sets the tolerance text justification.  

 Zeroes display:  

o Hide leading zeroes and Hide trailing zeroes: Lets you suppress leading 

and trailing zeroes in decimal tolerance Dimensions.  

o If you set the Format for Linear Dimension to Architectural or 

Engineering, you can also specify whether to hide zero feet (Hide if 0') and 

zero inches (Hide if 0").  

Dual Dimension 
 Precision: Sets the number of decimal places for alternate Dimensions in geometric 

tolerances.  

 Zeroes display:  

o Hide leading zeroes and Hide trailing zeroes: Lets you suppress leading 

and trailing zeroes in decimal alternate Dimensions.  

o If you set the Format for Linear Dimension to Architectural or 

Engineering, you can also specify whether to hide zero feet (Hide if 0') and 

zero inches (Hide if 0"). 

7.5.5. RichLineStyles settings 

RichLine entities consist of two or more parallel linear constructions created as one object. 

Before using RichLine entities, you can create custom RichLineStyles to specify the 

LineColor, LineStyle and other entity properties. The default RichLineStyle is named 

Standard. 

 



DraftSight - Configuration & Basic Customization 

74 

 

3
D

S
.C

O
M

 ©
 D

a
s
s
a

u
lt
 S

y
s
tè

m
e

s
  

| 
 C

o
n

fi
d
e

n
ti
a

l 
In

fo
rm

a
ti
o

n
  

| 
 0

1
/0

2
/2

0
1

2
  
re

f.
: 

D
o
c
u

m
e

n
t_

R
e
fe

re
n

c
e

 |
 

 To create RichLinesStyles : 

1. Click Format > RichLine Styles (or type RichLineStyle).  

In the Options dialog box, the Drafting Styles page opens and RichLine expands.  

2. Click New.  

3. In the Create new RichLineStyle dialog box, type a new name.  

4. Click OK.  

The new style appears in Style. 

 

 To edit RichLineStyles : 

1. Click Format > RichLine Styles (or type RichLineStyle).  

In the Options dialog box, the Drafting Styles page opens and RichLine expands.  

2. In Style, select a RichLineStyle.  

3. Edit settings in:  

 Line properties: Specify the offset, LineColor, and style for each line element 

that comprises the RichLine entity.  

o To add line elements to a RichLineStyle definition, click New.  

o To delete line elements from a RichLineStyle definition, select a line 

element and click Delete.  

 Display: Specify whether to display junctions at segment breaks and set the fill 

color.  

 Cap ends: Specify the start and end caps of the RichLine entity.  

4. Click OK. 

 

 To modify line elements in RichLineStyle definitions : 

1. Click Format > RichLine Styles (or type RichLineStyle).  

In the Options dialog box, the Drafting Styles page opens and RichLine expands.  

2. In Style, select a RichLineStyle.  

3. Under Line properties, modify:  

 Offset: The location of each line element in the RichLine entity is determined by 

its offset from the center of the entity. A line element with an offset of 0.0 is the 

center line.  

 LineColor: Double-click the selected element under Color.  

 Style: Double-click the selected element under Style. The list contains all 

LineStyles defined in the drawing. To add LineStyles, you must first create or 

import a LineStyle.  

4. Click OK. 
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 To modify junction and cap ends in RichLineStyle definitions : 

1. Click Format > RichLine Styles (or type RichLineStyle).  

In the Options dialog box, the Drafting Styles page opens and RichLine expands.  

2. In Style, select a RichLineStyle.  

3. Under Display, select or clear Show junctions and specify the Color for junctions.  

4. Under Cap ends, specify cap settings for the Start and End caps:  

 Angle: Sets the angle of the start and end caps relative to the direction of the first 

or last RichLine entity.  

 External arc: Caps the outer ends with an arc.  

 Internal arc: Joins the two line elements closest to the outer ones with an arc 

when there are four or more lines defining the RichLine entity.  

 Line: Caps the RichLine entity with a line segment. 

 

 To set a RichLine Style as active 

1. Click Format > RichLine Styles (or type RichLineStyle).  

In the Options dialog box, the Drafting Styles page opens and RichLine expands.  

2. In Style, select a RichLineStyle and click Activate.  

A  displays beside the active RichLineStyle.  

 

 To save RichLineStyles: 

1. Click Format > RichLine Styles (or type RichLineStyle).  

In the Options dialog box, the Drafting Styles page opens and RichLine expands.  

2. In Style, select a RichLineStyle and click Export.  

3. In the Save RichLine Style dialog box, type a file name and click Save. 
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 To import RichLineStyles 

1. Click Format > RichLine Styles (or type RichLineStyle).  

In the Options dialog box, the Drafting Styles page opens and RichLine expands.  

2. Click Load.  

3. In the Load RichLine Definitions dialog box, click Browse to navigate to the .mln 

style file and click Open.  

4. Click OK. 

 

 To rename a RichLine Style : 

1. Click Format > RichLine Styles (or type RichLineStyle).  

In the Options dialog box, the Drafting Styles page opens and RichLine expands.  

2. In Style, select a RichLineStyle and click Rename.  

3. In the Rename RichLineStyle dialog box, change the name.  

4. Click OK. 

 

 To delete RichLineStyles : 

1. Click Format > RichLine Styles (or type RichLineStyle).  

In the Options dialog box, the Drafting Styles page opens and RichLine expands.  

2. In Style, select a RichLine Style and click Delete.  

3. Click Yes to confirm the deletion. 

7.5.6. TableStyles settings 

You can create, modify, and delete TableStyles. You can also set a TableStyle as the active 

one. 
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 To create TableStyles : 

1. Click Format > Table Style (or type TableStyle).  

In the Options dialog box, the Drafting Styles page opens, and Table expands.  

2. Click New.  

3. In the Create new TableStyle dialog box, type a new name and click OK.  

The new TableStyle appears in Style. 

 To modify TableStyles : 

1. Click Format > Table Style (or type TableStyle).  

In the Options dialog box, the Drafting Styles page opens, and Table expands.  

2. In Filter, select an option:  

 All styles. Lists all of the styles defined in the drawing.  

 Styles in drawing. Lists only the styles that are referenced by Tables in the 

drawing.  

3. In Style, select a TableStyle.  

4. Under Cell style settings, in Contents, select the cell type to edit (Data, Head, or 

Title).  

5. Under Display, set:  

 Background color: Sets the background color for the table.  

 Align. Sets the justification and alignment of the text in the cells.  

6. Under Text, set:  

 Color: Sets the text color.  

 Style: Contains all TextStyles defined in the drawing. Click Display text styles  to 

define TextStyles for subsequent use.  

 Height: Sets the text size.  

7. Under Borders, set:  

 Color: Sets the border color.  

 Weight: Sets the border weight.  

 Apply to: Sets the specified Color and Weight to the border(s) you select.  

8. Under Cell settings:  

 Type a value for the Horizontal and Vertical cell margins (in drawing units).  

 In Table header orientation select an item to specify whether the table is 

generated downward or upward from the insertion point.  

The modifications will reflect in tables using that style. 

 To set a TableStyle as active : 

1. Click Format > Table Style (or type TableStyle).  

In the Options dialog box, the Drafting Styles page opens, and Table expands.  

2. In Style, select a TableStyle.  

3. Click Activate.  

A   displays beside the active TableStyle. 
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 To rename TableStyles : 

1. Click Format > Table Style (or type TableStyle).  

In the Options dialog box, the Drafting Styles page opens, and Table expands.  

2. In Style, select a TableStyle.  

3. Click Rename.  

4. In the Rename TableStyle dialog box, type a new name for the TableStyle.  

5. Click OK. 

 

 To delete TableStyles : 

You can delete TableStyles if they are not referenced by a Table in the drawing. 

You can also use the Clean command to remove unreferenced TableStyles. 

You cannot delete the Standard style. 

 

1. Click Format > Table Style (or type TableStyle).  

In the Options dialog box, the Drafting Styles page opens, and Table expands.  

2. In Style, select a TableStyle.  

3. Click Delete.  

4. Click Yes to confirm the deletion. 

 

7.6. Profiles 
The Profiles page of the Options dialog box lets you store individual profiles based on the 

settings you specify and manage the profiles. 

The name of the active profile is displayed at the top of the Options dialog box. 

 To manage settings profiles : 

1. Click Tools > Options (or type Options).  

In the Options dialog box, click Profiles  .  

- or -  

Type Profiles.  

A list of the available profiles is displayed.  

2. Use the following to manage profiles:  
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 Add. Opens the Named Profile dialog box. Type a Name and Description for 

the profile.  

 Rename. Lets you rename the selected profile. Rename opens the Rename 

Profile dialog box. Type a new Name or Description for the profile.  

 Delete. Lets you delete the selected profile. You cannot delete the active profile.  

 Import. Reads a profile from disk which was created with the Export option. You 

can import profile files from the same computer or different computers.  

 Export. Writes the selected profile as an .xml file.  

 Activate. Sets the selected profile as active.  

 Reset. Sets the values in the selected profile to the default settings. 

8. Setting the Language of the System 
Use the Language command to set the language to communicate with the software. 

Note: You must restart the software to update the language. 

8.1. To set the language of the system : 
1. Type Language at the command prompt.  

2. Specify a number for the language to use.  

Specify the ? option to list the supported languages.  

Note: Specifying 0 uses the operating system's default language.  

3. Save your work and type Exit to exit the software.  

4. Restart the software.  

The system uses the specified language. 

 Supported languages/command options : 

Supported languages/command options 

0 – Operating System default language 12 – Greek (not yet supported) 

1 - German 13 - Korean 

2 – English 14 - Vietnamese (not yet supported) 

3 - Turkish 15 – Catalan (not yet supported) 

4 – Hungarian (not yet supported) 16 – Thai (not yet supported) 

5 - Polish 17 – Dutch (not yet supported) 

6 - Japanese 18 - Russian 

7 - French 19 - Portuguese 

8 – Traditional Chinese 20 - Czech 

9 – Simplified Chinese 21 – Bulgarian (not yet supported) 

10 - Italian 22 – Slovak (not yet supported) 

11 - Spanish  
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9. Loading Applications 
Use the LoadApplication command to locate and load applications for use in the program. 

Typically, the application sends a message that it has been loaded successfully. You can 

then use the commands and functions provided by the application. 

Supported formats include: 

 

Lisp files (*.lsp)  

Menu Lisp files (*.mnl)  

Dynamic Link Libraries provided by application vendors (*.dll)  

You can load Dynamic Link Libraries (*.dll) provided for the software. 

10. Running Scripts 
Scripts (also referred to as macros) automate the execution of specific instructions or 

program commands one step at a time, which eliminate the need to enter the commands 

manually. 

This section discusses: 

 Writting and Running Script Files 

 Pausing Script Execution 

 Resuming Script Execution 

 Repeating a Script 

 Hiding the Command History Window 

 

10.1. Writting and Running Script Files 
Use the LoadScript command to execute a sequence of commands from a script file. 

Writing a Script File 
You can write a script file with any text editor or word processing program that is able to 

store ASCII text format (without the addition of any formatting information). 

 To create a script file : 

1. Enter the commands and instructions and their corresponding input values into the 

file in the same order in that the instructions are to execute. 

Command execution takes place line-by-line or instruction-by-instruction when 

separated by a space. Either an end of line or space character is interpreted as 

confirmation of the previous entry. 

2. Save the file in plain text format as an .scr file. 
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Example 
These lines define a script that sketches a Circle at the coordinates 5,5 with a radius of 10 

drawing units: 

Circle 

5,5 

10 

An equivalent is (note the spaces): 

Circle 5,5 10 

 Using the clipboard 

You can write script files with the Copy and Copy History commands.  

The command history window contains a list of program commands and data entries that 

you made during the program session. The history lets you reference and reconstruct the 

procedures you used. 

 To write script files by copying command history: 

1. Perform the command steps that you want to store.  

2. Type CommandHistory to open the separate command history window.  

3. Right-click and select Copy History.  

4. Open a text editor.  

5. Paste the command steps into the editor program.  

6. Save the file as an .scr file. 

Running a Script file 
 To run a script file : 

1. Click Tools > Run Script (or type LoadScript). 

2. Select a script and click Open. 

10.2. Pausing Script Execution 
Use the PauseScript command in a script file to pause the script for a specified time. 

 To pause script execution : 

1. Type PauseScript at the command prompt. 

2. Type the duration (in milliseconds) before issuing the next command. The value can 

be an integer between 0 and 32767. A value of 1000 pauses a script for one second. 

10.3. Resuming Script Execution 
The ResumeScript command lets you continue an interrupted script. 

You can interrupt a script by pressing Esc or Backspace. Scripts can also be interrupted by 

an error in the script file. 
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The command is helpful when writing and testing script files. 

 To resume an interrupted script : 

1. Type ResumeScript at the command prompt. 

 

10.4. Repeating a Script 
The ScriptN command repeats a script file. You can run scripts continuously until you 

interrupt them with the Esc or Backspace keys.  

The command is helpful for script files used for demonstrations in showrooms and 

exhibitions. 

 To repeat a script : 

1. Type ScriptN as the last command in a script file. 

10.5. Hiding the Command History Window 
The HideCommandHistory command closes the command history window. 

 To hide the command history window : 

Do one of the following : 

1. Type HideCommandHistory at the command prompt or Press F2. 

 

11. Customizing LineStyles 
LineStyles are used in drawings to enforce the informative value of drawings and to conform 

with industry standards. The LineStyle command lets you load and manage LineStyles. You 

can assign LineStyles to layers or directly to new entities. To use LineStyles, you must load 

them from files that define the dash-dot patterns. 

11.1. LineStyle Files and File Location 
LineStyle definition files are stored in ASCII text files using the .lin extension. 

 To change the search location for LineStyle definition files : 

1. Click Tools > Options (or type Options). 

2. In the Options dialog box, Click File Locations . 

3. Expand Drawing Support > LineStyle File. 

4. Select the path and click Browse (or double-click the path). 

5. In the Browse For Folder dialog box, browse to the new path and click OK twice. 
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11.2. LineStyle File Syntax 
You can place comments in the file by beginning the file lines with a semicolon followed by 

text. 

A LineStyle format comprises two lines: 

 The first line, or header, starts with an asterisk and contains the LineStyle name 

followed by a comma and a symbolic representation of the LineStyle made up of a 

string of dashes, spaces, and dots.  

 The second line, or definition line, contains a geometric description of the LineStyle. 

Examples : 

 

 Header: *LineStyle [, LineStyle description]  

 Definition line: Line segment length 1, Line segment length 2, ..., Line segment length 

n  

The following example shows the definition of a dash-dot LineStyle: 

 

The header includes an asterisk followed by the line LineStyle (Dashdot). A comma 

separates the symbolic representation of the LineStyle ("_ . _ ."). 

The second line contains the LineStyle's geometric definition. 

All definitions of dashes, dots, and spaces are separated by commas: 

 Dash: The drawing elements are shown as positive figures, for instance 0.5 

represents a dash ("pen down") with a length of 0.5 drawing units.  

 Dot: Dots are shown as 0 values.  

 Space: Spaces are shown as negative figures, for instance -0.25 represents the 

space ("pen up") in which no line should be drawn.  

The length specifications represent drawing units when the LineScale factor is set to 1.00. 

11.3. Complex LineStyles 
Complex LineStyles specify single - possibly broken - lines interspersed with symbols. These 

LineStyles can include text or shape definitions as pattern descriptors along with the dash 

and dot descriptors of simple LineStyles. Usually they denote boundaries, contours, or 

utilities. 

Text elements or shapes embedded in Lines are always drawn completely (never trimmed). 
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Syntax 
The syntax for complex LineStyles is similar to that of simple LineStyles. 

The syntax for text and shape descriptors in a LineStyle description is a comma-delimited list 

of pattern descriptors as follows: 

Shape definitions 
[Shape_Name, SHX_Filename] 

- or - 

[Shape_Name, SHX_Filename, Transformation] 

The Shape_Name argument specifies the name of the shape to draw. This argument must 

be included. The shape name must exist in the specified shape file. 

The SHX_Filename argument specifies the name of a compiled shape definition file (.shx). 

This argument must be included. If no path is defined for the file name (which is 

recommended), the library path is searched. 

Text definitions 
["String", TextStyle_Name] 

- or - 

["String", TextStyle_Name, Transformation] 

The String argument defines the text to use in the complex LineStyle. You cannot use the 

characters ‘ (single quotation) or " (double quotation) in the string. To use these characters, 

use a control code %% with the sub-seeding ASCII value for the character. 

The TextStyle_Name argument determines the TextStyle to elaborate. 

Transformation specifications 
The Transformation argument is optional and can be any series of the following, each 

preceded by a comma: 

R=value Relative rotation 

A=value Absolute rotation 

S=value Scale 

X=value X offset 

Y=value Y offset 

 

In this syntax, the value argument is a signed decimal number (for example, 1, -0.25, 0.3). 

The rotation arguments are in degrees, the other arguments are in LineStyle-scaled drawing 

units. 

The preceding transformation letters, if used, must be followed by an equal sign and a 

number. 
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11.4. Loading and Setting LineStyles 
Use the LineStyle command to load and set LineStyles. Choose a LineStyle to display on 

the currently active segment of the drawing. 

To set the LineStyles pattern definition and LineStyles definition file syntax, refer to the topic 

Customizing LineStyles. 

 To load LineStyles : 

1. Click Format > Line Style (or type LineStyle).  

2. In the dialog box, click Load.  

The Load LineStyles dialog box displays the LineStyles contained in the .lin file. 

3. Click Browse to select a LineStyle file, and click Open.  

4. Select one or more LineStyles in the list.  

To select more than one LineStyle, press Ctrl and select multiple LineStyles. 

5. Click OK.  

The selected LineStyles appear in the Line Style dialog box. However, a selected 

LineStyle does not become the active LineStyle automatically. It is only added to the 

list of LineStyles that are available. You have to set the active LineStyle explicitly. 

6. Click OK. 

 

 To set the active LineStyle : 

1. Click Format > Line Style (or type LineStyle).  

2. In Show, select the LineStyles you want to appear in the dialog box:  

 All LineStyles  

 LineStyles in Use  

 Referenced LineStyles  

3. Click Reverse Filter to invert the option you selected.  

For example, reversing LineStyles in Use shows all unused LineStyles.  

The LineStyle list shows the dash-dot patterns for the LineStyles. These LineStyles 

can be loaded from LineStyle definition files or inherited from drawings.  

Every drawing has three LineStyle definitions:  

 Continuous. Solid line without a pattern.  

 ByBlock. Entities are drawn as continuous lines until they are grouped into a 

Block. The entities then inherit the LineStyle setting when you insert the Block 

into the drawing.  

 ByLayer. New entities adopt the LineStyle of the Layer on which they are 

placed.  

4. Select the LineStyle you want to activate.  

5. Click Activate.  

6. The LineStyle is used when you draw a new entity. The LineStyle of the active Layer 

does not change. 
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 To delete a LineStyle : 

1. Click Format > Line Style (or type LineStyle).  

2. Select one or more LineStyles in the list.  

3. Click Delete. 

Note : You can only delete LineStyles that are currently not in use. 

 To edit a LineStyle : 

1. Click Format > Line Style (or type LineStyle).  

2. Select a LineStyle in the list.  

3. Click Show Parameters, and under Parameters, edit the options:  

 Name. Specifies the name of the LineStyle definition to store in the drawing.  

 Description. Specifies a Note or symbolic representation for the LineStyle to 

display in the Line Style dialog box.  

 Global scale. Scales the LineStyles so they fit to the units of measurement.  

 Entities scale. Sets a LineStyle scale factor for new entities relative to the 

general LineStyle scale factor.  

 Scale based on sheet's units. Forces LineStyles to be drawn at the same 

scale as the Viewport scale. Clear the option to scale LineStyles equally in 

the model and Sheet. 

 

 To modify the LineStyle of existing drawing entities : 

Do one of the following : 

 Change the LineStyle property in the Properties palette.  

 Select one or more entities in the drawing and select a different LineStyle in the 

Properties toolbar.  

 Use the ModifyProperties command. You must use the exact name of the loaded 

LineStyle you want to apply. 

12. Customizing Hatch Patterns 
Hatches are designed by repeating a number of lines. These lines can be rotated at any 

angle, start at various points, and be spaced at different intervals. It is also possible to 

generate dash-dotted sequences instead of elongated dashes. 

You can load Hatch patterns defined in pattern files using the Hatch command, and you can 

select the pattern from the Hatch dialog box. Once you set up a new pattern file, it is used 

as the default file until you select another pattern. 

12.1. Hatch Pattern Files and File Location 
Predefined Hatch patterns are stored in .pat files (pattern files). 

To generate a pattern file, use a text editor to create a file with a .pat extension. 
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 To change the seach location for pattern files : 

1. Click Tools > Options (or type Options).  

2. In the Options dialog box, click File Locations  .  

3. Expand System > Support Files Search Path. 

12.2. Hatch Pattern File Syntax 
Hatch patterns are made up of a header followed by the name of the Hatch pattern. An 

asterisk (*) indicates the beginning of the Hatch pattern name, this can be followed by a 

comma and the pattern description. The next line contains the actual Hatch pattern 

definition. Every Hatch pattern definition starts on a separate line and contains the following 

elements: 

 The angle of the line  

 The X and Y coordinates of where the line is to begin  

 X and Y spacing of the offset  

 Line segment length  

The line segment lengths are needed for elongated and dotted Hatch lines. They are not 

required for continuous lines. 

You can enter comments into the Hatch file header for documentation purposes. These 

comment lines begin with a semicolon. 

Header *Hatch pattern name [,Description of the 
pattern] 

1st Hatch line : Angle, X start point, Y start point, X spacing, 
Y spacing [,Ls1, Ls2, …, Lsn] 

2nd Hatch line Same as 1st Hatch line 

n-th Hatch line Same as 1st Hatch line 

 

[Ls1,Ls2,...,Lsn] = Line segment length 1, Line segment length 2, ..., Line segment length n 

The Hatch pattern name must be less than 15 characters. The description must be less than 

80 characters. 

No more than six line segment length entries are permitted per Hatch line definition. 

Examples 
 

Example 1 : Horizontal Hatch 

This example shows a Hatch pattern with the name HLINE using a 0° angle. The start point 

is located at 0,0 and the Y line offset is 1 drawing unit wide. 
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Example 2 : Dash dot Hatch 

This example shows a dash dot Hatch pattern drawn at a 45° angle. The start point is 

located at 0,0 and the Hatch line offset is 1 drawing unit wide. The dash length is 0.5 

drawing units. A space of 0.25 drawing units separates each dot and dash. 

 

Example 3 : Parquet Hatch 

This example shows a parquet Hatch pattern that comprises a number of Hatch lines. The 

pattern contains 4 parquets with a width of 0.25 drawing units. 

This pattern is used to create a pattern containing five, 0° Hatch lines and 5, 90° Hatch lines. 

The start points are offset by 0.25 units at 90° in the X direction and 0° in the Y direction. 
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13. Command Variables 
Command variables control the state of drawings, options and preferences in commands, 

aspects of the user interface, and settings for drawing, editing, and viewing modes. 

You can use some variables like a command (especially those that turn on and off certain 

states of the drawing environment). 

A comprehensive list of the DraftSight Command variables (and Legacy variables handled 

by DraftSight) can be found in the DraftSight Help files, Contents Tab, under the topic 

Command Variables. 

Note: Some variables are present only for compatibility with other CAD programs or for 

legacy reasons to older software. 

13.1. Setting Command Variables 
Use the SetVariable command to check, set, and change current command variable 

settings. Command variables store settings and preferences for commands and functions as 

well as for drawing, editing, and viewing modes. 

 To view or set command variables : 

1. Type SetVariable at the command prompt.  

2. Type the variable name.  

The current value of the variable displays as default.  

3. Type the new variable value.  

Note: Some of the variables are read-only. 

 

 To list all command variables : 

1. Type SetVariable at the command prompt.  

2. Type ?.  

3. Type *.  

In the command window, the command variables are listed alphabetically with their 

current values. 

Note : You can type variable names at the command prompt directly instead of calling the 

SetVariable command explicitly. 

Example : 

The following toggles filling mode for entities: 

 

 

 


